aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7a488dd6e..3c315afe6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1209,6 +1209,23 @@ AC_ARG_ENABLE([experimental],
1209AC_MSG_RESULT($enable_experimental) 1209AC_MSG_RESULT($enable_experimental)
1210AM_CONDITIONAL([HAVE_EXPERIMENTAL], [test "x$enable_experimental" = "xyes"]) 1210AM_CONDITIONAL([HAVE_EXPERIMENTAL], [test "x$enable_experimental" = "xyes"])
1211 1211
1212# should malicious code be compiled (should only be used for testing)?
1213AC_MSG_CHECKING(whether to compile malicious code)
1214AC_ARG_ENABLE([malicious],
1215 [AS_HELP_STRING([--enable-malicious], [enable compiling malicious code])],
1216 [if test "x$enableval" = "xno"
1217 then
1218 malicious=0
1219 else
1220 malicious=1
1221 fi],
1222 [malicious=0
1223 enable_malicious=no])
1224AC_MSG_RESULT($enable_malicious)
1225AM_CONDITIONAL([ENABLE_MALICIOUS], [$malicious])
1226AC_DEFINE_UNQUOTED([ENABLE_MALICIOUS], [$malicious],
1227 [enable compilation of malicious code])
1228
1212# should services be started by default when a peer starts? Some services may 1229# should services be started by default when a peer starts? Some services may
1213# choose to never start by default and it is upto the service/module developer to 1230# choose to never start by default and it is upto the service/module developer to
1214# decide it by having "AUTOSTART = NO" instead of "AUTOSTART = @AUTOSTART" in 1231# decide it by having "AUTOSTART = NO" instead of "AUTOSTART = @AUTOSTART" in