aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0b434b1aa..356f6d0d2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -455,6 +455,27 @@ AS_IF([test "x$include_manpages" = "xyes"],
455 AC_DEFINE([INCLUDE_MANPAGES],[0],[Not including the man pages in the build and installation]) 455 AC_DEFINE([INCLUDE_MANPAGES],[0],[Not including the man pages in the build and installation])
456 ]) 456 ])
457 457
458# Do we have texinfo4? If yes, it is used to set texinfo4 specific switches
459# (not syntax!) to the commandline tools which generate the html. If not,
460# texinfo5 switches are used. This comes with no version checks, is
461# enabled only at distributors action (ie defaults to "no").
462# Mantis #3914 for more details (https://bugs.gnunet.org/view.php?id=3914)
463AC_MSG_CHECKING(whether to enable texinfo4 switches)
464AC_ARG_ENABLE([texinfo4],
465 [AS_HELP_STRING([--enable-texinfo4], [Use texinfo version 4 specific switches])],
466 [activate_texinfo4=${enableval}],
467 [activate_texinfo4=no])
468AC_MSG_RESULT($activate_texinfo4)
469AS_IF([test "x$activate_texinfo4" = "xyes"],
470 [
471 AM_CONDITIONAL([ACTIVATE_TEXINFO4],true)
472 AC_DEFINE([ACTIVATE_TEXINFO4],[1],[Using texinfo version 4 specific switches])
473 ],[
474 AM_CONDITIONAL([ACTIVATE_TEXINFO4],false)
475 AC_DEFINE([INCLUDE_MANPAGES],[0],[Using texinfo version 5 or later switches])
476 ])
477
478
458# Adam shostack suggests the following for Windows: 479# Adam shostack suggests the following for Windows:
459# -D_FORTIFY_SOURCE=2 -fstack-protector-all 480# -D_FORTIFY_SOURCE=2 -fstack-protector-all
460AC_ARG_ENABLE(gcc-hardening, 481AC_ARG_ENABLE(gcc-hardening,