aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 8 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index f53d65006..5f10599be 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
1# This file is part of GNUnet. 1# This file is part of GNUnet.
2# (C) 2001--2018 GNUnet e.V. 2# (C) 2001--2019 GNUnet e.V.
3# 3#
4# GNUnet is free software: you can redistribute it and/or modify it 4# GNUnet is free software: you can redistribute it and/or modify it
5# under the terms of the GNU Affero General Public License as published 5# under the terms of the GNU Affero General Public License as published
@@ -206,6 +206,13 @@ AM_CONDITIONAL(HAVE_SSH_BINARY, $VAR_SSH_BINARY)
206AM_CONDITIONAL(HAVE_SSH_KEY, ssh -D 12345 -o "BatchMode yes" -o "UserKnownHostsFile /tmp/gnunet_test_cosks_ssh_garbage" -o "StrictHostKeyChecking no" 127.0.0.1 echo -n) 206AM_CONDITIONAL(HAVE_SSH_KEY, ssh -D 12345 -o "BatchMode yes" -o "UserKnownHostsFile /tmp/gnunet_test_cosks_ssh_garbage" -o "StrictHostKeyChecking no" 127.0.0.1 echo -n)
207rm -f /tmp/gnunet_test_cosks_ssh_garbage 207rm -f /tmp/gnunet_test_cosks_ssh_garbage
208 208
209# autotools' m4 for python has no maximum version!
210# python3.7 for tests
211m4_define_default([_AM_PYTHON_INTERPRETER_LIST],[python3 python3.7 python])
212AM_PATH_PYTHON([3.7],, [:])
213AC_SUBST([PYTHON])
214AM_CONDITIONAL([HAVE_PYTHON], [test "$PYTHON" != :])
215
209# iptables is a soft requirement to run tests 216# iptables is a soft requirement to run tests
210AC_PATH_TARGET_TOOL(VAR_IPTABLES_BINARY, iptables, false) 217AC_PATH_TARGET_TOOL(VAR_IPTABLES_BINARY, iptables, false)
211 218
@@ -1208,10 +1215,6 @@ AM_CONDITIONAL(HAVE_JSON, [test x$jansson = x1])
1208# restore LIBS 1215# restore LIBS
1209LIBS=$SAVE_LIBS 1216LIBS=$SAVE_LIBS
1210 1217
1211# check for python & pexpect (used for some testcases only)
1212AM_PATH_PYTHON([2.6],, [:])
1213AM_CONDITIONAL([HAVE_PYTHON], [test "$PYTHON" != :])
1214
1215# check for gettext 1218# check for gettext
1216AM_GNU_GETTEXT([external]) 1219AM_GNU_GETTEXT([external])
1217AM_GNU_GETTEXT_VERSION([0.18.1]) 1220AM_GNU_GETTEXT_VERSION([0.18.1])