aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 30 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 24915a14e..687ea1e20 100644
--- a/configure.ac
+++ b/configure.ac
@@ -461,6 +461,27 @@ else
461 AM_CONDITIONAL(HAVE_LIBGNURL, false) 461 AM_CONDITIONAL(HAVE_LIBGNURL, false)
462fi 462fi
463 463
464# libcurl-gnutls
465LIBCURL_CHECK_CONFIG(,7.34.0,[curl=true],[curl=false])
466if test "x$curl" = xtrue
467then
468 AC_CHECK_HEADERS([curl/curl.h],
469 AC_CHECK_DECLS(CURLINFO_TLS_SESSION,[curl=true],[curl=false],[[#include <curl/curl.h>]]),
470 [curl=false])
471 # need libcurl-gnutls.so, everything else is not acceptable
472 AC_CHECK_LIB([curl-gnutls],[curl_easy_getinfo],,[curl=false])
473 # cURL must support CURLINFO_TLS_SESSION, version >= 7.34
474
475fi
476if test x$curl = xfalse
477then
478 AM_CONDITIONAL(HAVE_LIBCURL, false)
479 AC_MSG_WARN([GNUnet requires libcurl-gnutls >= 7.34])
480else
481 AM_CONDITIONAL(HAVE_LIBCURL, true)
482 AC_DEFINE([HAVE_LIBCURL],[1],[Have CURL])
483fi
484
464 485
465# libidn 486# libidn
466AC_MSG_CHECKING([if Libidn can be used]) 487AC_MSG_CHECKING([if Libidn can be used])
@@ -1197,7 +1218,7 @@ AC_ARG_ENABLE([malicious],
1197 [malicious=0 1218 [malicious=0
1198 enable_malicious=no]) 1219 enable_malicious=no])
1199AC_MSG_RESULT($enable_malicious) 1220AC_MSG_RESULT($enable_malicious)
1200AM_CONDITIONAL([ENABLE_MALICIOUS], [$malicious]) 1221AM_CONDITIONAL([ENABLE_MALICIOUS], [1=$malicious])
1201AC_DEFINE_UNQUOTED([ENABLE_MALICIOUS], [$malicious], 1222AC_DEFINE_UNQUOTED([ENABLE_MALICIOUS], [$malicious],
1202 [enable compilation of malicious code]) 1223 [enable compilation of malicious code])
1203 1224
@@ -1552,10 +1573,16 @@ fi
1552# libgnurl 1573# libgnurl
1553if test "x$gnurl" = "x0" 1574if test "x$gnurl" = "x0"
1554then 1575then
1555 AC_MSG_NOTICE([NOTICE: libgnurl not found. http client support will not be compiled.]) 1576 if test "x$curl" = "x0"
1556 AC_MSG_WARN([libgnurl not found. hostlist daemon will not be compiled, and you probably WANT hostlist daemon]) 1577 then
1578 AC_MSG_NOTICE([NOTICE: libgnurl not found. http client support will not be compiled.])
1579 AC_MSG_WARN([ERROR: libgnurl not found. hostlist daemon will not be compiled, and you probably WANT the hostlist daemon])
1580 else
1581 AC_MSG_NOTICE([WARNING: libgnurl not found, trying to use libcurl-gnutls instead.])
1582 fi
1557fi 1583fi
1558 1584
1585
1559# bluetooth 1586# bluetooth
1560if test "x$bluetooth" = "x0" 1587if test "x$bluetooth" = "x0"
1561then 1588then