aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bb4f74366..c0bf33421 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1216,6 +1216,15 @@ AC_ARG_ENABLE([wachs],
1216AC_MSG_RESULT($enable_wachs) 1216AC_MSG_RESULT($enable_wachs)
1217AM_CONDITIONAL([HAVE_WACHS], [test "x$enable_wachs" = "xyes"]) 1217AM_CONDITIONAL([HAVE_WACHS], [test "x$enable_wachs" = "xyes"])
1218 1218
1219# REST API
1220AC_MSG_CHECKING(whether to compile REST API)
1221AC_ARG_ENABLE([rest],
1222 [AS_HELP_STRING([--enable-rest], [enable REST])],
1223 [enable_rest=${enableval}],
1224 [enable_rest=no])
1225AC_MSG_RESULT($enable_rest)
1226AM_CONDITIONAL([HAVE_REST], [test "x$enable_rest" = "xyes"])
1227
1219# should malicious code be compiled (should only be used for testing)? 1228# should malicious code be compiled (should only be used for testing)?
1220AC_MSG_CHECKING(whether to compile malicious code) 1229AC_MSG_CHECKING(whether to compile malicious code)
1221AC_ARG_ENABLE([malicious], 1230AC_ARG_ENABLE([malicious],
@@ -1520,6 +1529,7 @@ src/util/Makefile
1520src/util/resolver.conf 1529src/util/resolver.conf
1521src/vpn/Makefile 1530src/vpn/Makefile
1522src/vpn/vpn.conf 1531src/vpn/vpn.conf
1532src/rest/Makefile
1523pkgconfig/Makefile 1533pkgconfig/Makefile
1524pkgconfig/gnunetarm.pc 1534pkgconfig/gnunetarm.pc
1525pkgconfig/gnunetats.pc 1535pkgconfig/gnunetats.pc