aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 714610a01..78f7be9ab 100644
--- a/configure.ac
+++ b/configure.ac
@@ -326,7 +326,14 @@ AC_LANG_POP(C)
326fi # $build = $target 326fi # $build = $target
327 327
328# libcurl 328# libcurl
329LIBCURL_CHECK_CONFIG(,7.21.3,,AC_MSG_ERROR([GNUnet requires libcurl >= 7.21.3])) 329LIBCURL_CHECK_CONFIG(,7.21.3,curl=1,curl=0)
330if test "$curl" = 1
331then
332 AM_CONDITIONAL(HAVE_LIBCURL, true)
333 AC_DEFINE([HAVE_LIBCURL],[1],[Have libcurl])
334else
335 AM_CONDITIONAL(HAVE_LIBCURL, false)
336fi
330# restore LIBS 337# restore LIBS
331LIBS=$SAVE_LIBS 338LIBS=$SAVE_LIBS
332 339
@@ -1123,6 +1130,12 @@ then
1123 AC_MSG_NOTICE([NOTICE: sqlite not found. sqLite support will not be compiled.]) 1130 AC_MSG_NOTICE([NOTICE: sqlite not found. sqLite support will not be compiled.])
1124fi 1131fi
1125 1132
1133# libcurl
1134if test "x$curl" = "x0"
1135then
1136 AC_MSG_NOTICE([NOTICE: libcurl not found. http client support will not be compiled.])
1137fi
1138
1126#gnutls 1139#gnutls
1127if test x$gnutls != xtrue 1140if test x$gnutls != xtrue
1128then 1141then