aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 13 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 94c0a7689..bae6c3e8d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -984,8 +984,8 @@ AS_IF([test "x$curl" = xtrue],[
984 AC_CHECK_HEADER([curl/curl.h], 984 AC_CHECK_HEADER([curl/curl.h],
985 AC_CHECK_DECLS(CURLINFO_TLS_SESSION,[curl=true],[curl=false],[[#include <curl/curl.h>]]), 985 AC_CHECK_DECLS(CURLINFO_TLS_SESSION,[curl=true],[curl=false],[[#include <curl/curl.h>]]),
986 [curl=false]) 986 [curl=false])
987 # need libcurl-gnutls.so, everything else is not acceptable 987 # need libcurl-gnutls.so for proxy, warn later if not found.
988 AC_CHECK_LIB([curl-gnutls],[curl_easy_getinfo],,[curl=false]) 988 AC_CHECK_LIB([curl-gnutls],[curl_easy_getinfo],[curl_gnutls=true],[curl_gnutls=false])
989 # cURL must support CURLINFO_TLS_SESSION, version >= 7.34 989 # cURL must support CURLINFO_TLS_SESSION, version >= 7.34
990]) 990])
991 991
@@ -1000,7 +1000,7 @@ AS_IF([test "$gnurl" = 1],
1000 AC_DEFINE([HAVE_LIBGNURL],[0],[Lacking libgnurl]) 1000 AC_DEFINE([HAVE_LIBGNURL],[0],[Lacking libgnurl])
1001 AM_CONDITIONAL(HAVE_LIBCURL, true) 1001 AM_CONDITIONAL(HAVE_LIBCURL, true)
1002 AC_DEFINE([HAVE_LIBCURL],[1],[Have libcurl])], 1002 AC_DEFINE([HAVE_LIBCURL],[1],[Have libcurl])],
1003 [AC_MSG_WARN([ERROR: GNUnet requires libcurl-gnutls or gnurl >= 7.34]) 1003 [AC_MSG_ERROR([GNUnet requires libcurl or gnurl >= 7.34])
1004 AM_CONDITIONAL(HAVE_LIBGNURL, false) 1004 AM_CONDITIONAL(HAVE_LIBGNURL, false)
1005 AC_DEFINE([HAVE_LIBGNURL],[0],[Lacking libgnurl]) 1005 AC_DEFINE([HAVE_LIBGNURL],[0],[Lacking libgnurl])
1006 AM_CONDITIONAL(HAVE_LIBCURL, false) 1006 AM_CONDITIONAL(HAVE_LIBCURL, false)
@@ -2080,11 +2080,16 @@ AS_IF([test "$gnurl" = "0"],
2080 [AS_IF([test "x$curl" = "xfalse"], 2080 [AS_IF([test "x$curl" = "xfalse"],
2081 [AC_MSG_WARN([libgnurl not found. http client support will not be compiled.]) 2081 [AC_MSG_WARN([libgnurl not found. http client support will not be compiled.])
2082 AC_MSG_WARN([IMPORTANT: No HTTP client library found. HTTP transports and hostlist daemon will not be compiled, and you probably WANT the hostlist daemon]) 2082 AC_MSG_WARN([IMPORTANT: No HTTP client library found. HTTP transports and hostlist daemon will not be compiled, and you probably WANT the hostlist daemon])
2083 curl_msg="no"], 2083 http_client="none"],
2084 [AC_MSG_NOTICE([libgnurl not found, trying to use libcurl-gnutls instead.]) 2084 [AC_MSG_NOTICE([Using libcurl as HTTP client library.])
2085 curl_msg="yes"])], 2085 http_client="curl"])],
2086 [gnurl_msg="yes" 2086 [AC_MSG_NOTICE([Using libgnurl as HTTP client library.])
2087 http_client="gnurl"
2087 transport_msg="$transport_msg http_client"]) 2088 transport_msg="$transport_msg http_client"])
2089AS_IF([test "x$curl" = "xtrue" -a "x$curl_gnutls" != "xtrue"],
2090 [AC_MSG_WARN([libcurl TLS backend is not gnutls. The GNS Proxy will likely not function properly.])
2091 http_client="curl-openssl"],
2092 [http_client="curl-gnutls"])
2088# -- ifconfig 2093# -- ifconfig
2089AS_IF([test "$VAR_IFCONFIG_BINARY" = "false"], 2094AS_IF([test "$VAR_IFCONFIG_BINARY" = "false"],
2090 [ifconfig_msg="no (optional, some features will not work)"], 2095 [ifconfig_msg="no (optional, some features will not work)"],
@@ -2160,8 +2165,7 @@ Default Interface: ${interface_msg}
2160MySQL: ${mysql_msg} 2165MySQL: ${mysql_msg}
2161PostgreSQL: ${postgres_msg} 2166PostgreSQL: ${postgres_msg}
2162sqlite3: ${sqlite_msg} 2167sqlite3: ${sqlite_msg}
2163gnurl: ${gnurl_msg} 2168http client: ${http_client}
2164curl: ${curl_msg}
2165bluetooth: ${bluetooth_msg} 2169bluetooth: ${bluetooth_msg}
2166jansson: ${jansson_msg} 2170jansson: ${jansson_msg}
2167iptables: ${iptables_msg} 2171iptables: ${iptables_msg}