aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cd159115e..b74bb267f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -408,6 +408,20 @@ then
408 AC_DEFINE([HAVE_OPUS],[1],[Have libopus library]) 408 AC_DEFINE([HAVE_OPUS],[1],[Have libopus library])
409fi 409fi
410 410
411# libogg
412AC_CHECK_LIB(ogg, ogg_stream_flush_fill,
413 [AC_CHECK_HEADERS([ogg/ogg.h],
414 AM_CONDITIONAL(HAVE_OGG, true)
415 ogg=1
416 AC_DEFINE(HAVE_OGG,1,[Have ogg]),
417 AM_CONDITIONAL(HAVE_OGG, false)
418 ogg=0
419 AC_DEFINE(HAVE_OGG,0,[lacking ogg]))],
420 AM_CONDITIONAL(HAVE_OGG, false)
421 ogg=0)
422
423
424
411gst=0 425gst=0
412PKG_CHECK_MODULES( 426PKG_CHECK_MODULES(
413 [GST], 427 [GST],
@@ -421,7 +435,7 @@ PKG_CHECK_MODULES(
421 ]) 435 ])
422 436
423# Pulse Audio 437# Pulse Audio
424if test "x$pulse" != "x1" -o "x$opus" != "x1" 438if test "x$pulse" != "x1" -o "x$opus" != "x1" -o "x$ogg" != "x1"
425then 439then
426 if test "x$gst" != "x1" -o "x$opus" != "x1" 440 if test "x$gst" != "x1" -o "x$opus" != "x1"
427 then 441 then