aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 10 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index d031b9998..39b78fd3e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1377,24 +1377,25 @@ AM_CONDITIONAL([ENABLE_MALICIOUS], [test 1=$malicious])
1377AC_DEFINE_UNQUOTED([ENABLE_MALICIOUS], [$malicious], 1377AC_DEFINE_UNQUOTED([ENABLE_MALICIOUS], [$malicious],
1378 [enable compilation of malicious code]) 1378 [enable compilation of malicious code])
1379 1379
1380# should services be started by default when a peer starts? Some services may 1380# should services be started on demand when needed? Some services may choose to
1381# choose to never start by default and it is upto the service/module developer to 1381# never start by default and it is up to the service/module developer to decide
1382# decide it by having "AUTOSTART = NO" instead of "AUTOSTART = @AUTOSTART@" in 1382# by having "START_ON_DEMAND = NO" instead of "START_ON_DEMAND = @START_ON_DEMAND@"
1383# the service/module's conf.in file. 1383# in the service/module's conf.in file.
1384AUTOSTART="YES" 1384# See also FORCESTART for an unconditional immediate start.
1385AC_MSG_CHECKING(whether to auto-start peer's services by default) 1385START_ON_DEMAND="YES"
1386AC_MSG_CHECKING(whether to start peer's services on demand by default)
1386AC_ARG_ENABLE([autostart], 1387AC_ARG_ENABLE([autostart],
1387 [AS_HELP_STRING([--disable-autostart], [do not start peer's services by default])], 1388 [AS_HELP_STRING([--disable-autostart], [do not start peer's services by default])],
1388 [enable_autostart=${enableval} 1389 [enable_autostart=${enableval}
1389 if test "x$enable_autostart" == "xno" 1390 if test "x$enable_autostart" == "xno"
1390 then 1391 then
1391 AUTOSTART="NO" 1392 START_ON_DEMAND="NO"
1392 fi 1393 fi
1393 ], 1394 ],
1394 [enable_autostart=yes]) 1395 [enable_autostart=yes])
1395AC_MSG_RESULT($enable_autostart) 1396AC_MSG_RESULT($enable_autostart)
1396#AM_CONDITIONAL([HAVE_AUTOSTART], [test "x$enable_autostart" = "xyes"]) 1397#AM_CONDITIONAL([HAVE_START_ON_DEMAND], [test "x$enable_autostart" = "xyes"])
1397AC_SUBST(AUTOSTART) 1398AC_SUBST(START_ON_DEMAND)
1398 1399
1399# should memory statistics be kept (very expensive CPU-wise!) 1400# should memory statistics be kept (very expensive CPU-wise!)
1400AC_MSG_CHECKING(whether to create expensive statistics on memory use) 1401AC_MSG_CHECKING(whether to create expensive statistics on memory use)