aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 14 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c68978d20..374f00cab 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1032,7 +1032,14 @@ AC_ARG_WITH(gnutls,
1032 AC_CHECK_LIB([gnutls], [gnutls_priority_set], 1032 AC_CHECK_LIB([gnutls], [gnutls_priority_set],
1033 gnutls=true))]) 1033 gnutls=true))])
1034AM_CONDITIONAL(HAVE_GNUTLS, test x$gnutls = xtrue) 1034AM_CONDITIONAL(HAVE_GNUTLS, test x$gnutls = xtrue)
1035AC_DEFINE_UNQUOTED([HAVE_GNUTLS], $gnutls, [We have gnutls]) 1035AC_DEFINE_UNQUOTED([HAVE_GNUTLS], $gnutls, [We have GnuTLS])
1036
1037gnutls_dane=0
1038AC_CHECK_HEADERS([gnutls/dane.h],
1039 AC_CHECK_LIB([gnutls-dane], [dane_verify_crt_raw],
1040 gnutls_dane=true))
1041AM_CONDITIONAL(HAVE_GNUTLS_DANE, test x$gnutls_dane = xtrue)
1042AC_DEFINE_UNQUOTED([HAVE_GNUTLS_DANE], $gnutls_dane, [We have GnuTLS with DANE support])
1036 1043
1037 1044
1038# Test if we are building for superMUC 1045# Test if we are building for superMUC
@@ -1470,7 +1477,12 @@ fi
1470#gnutls 1477#gnutls
1471if test x$gnutls != xtrue 1478if test x$gnutls != xtrue
1472then 1479then
1473 AC_MSG_NOTICE([NOTICE: gnutls not found, gnunet-gns-proxy will not be built]) 1480 AC_MSG_NOTICE([NOTICE: GnuTLS not found, gnunet-gns-proxy will not be built])
1481else
1482if test x$gnutls_dane != xtrue
1483then
1484 AC_MSG_NOTICE([NOTICE: GnuTLS has no DANE support, DANE validation will not be possible])
1485fi
1474fi 1486fi
1475 1487
1476# java ports 1488# java ports