aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3d061c905..699a63d3d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -247,6 +247,17 @@ LIBCURL_CHECK_CONFIG(,7.20.1,,AC_MSG_ERROR([GNUnet requires libcurl >= 7.20.1]))
247# restore LIBS 247# restore LIBS
248LIBS=$SAVE_LIBS 248LIBS=$SAVE_LIBS
249 249
250# glpk
251glpk=0
252AC_CHECK_HEADERS([glpk.h])
253if test "$ac_cv_header_glpk_h" = yes; then
254AM_CONDITIONAL(HAVE_GLPK, 1)
255AC_DEFINE_UNQUOTED([HAVE_GLPK], test x$glpk = xtrue, [We have GLPK])
256else
257AM_CONDITIONAL(HAVE_GLPK, test x$glpk = xtrue)
258AC_MSG_WARN([GLPK not installed.])
259fi
260
250# test for kvm and kstat (for CPU stats under BSD/Solaris) 261# test for kvm and kstat (for CPU stats under BSD/Solaris)
251AC_CHECK_LIB([kvm],[kvm_open]) 262AC_CHECK_LIB([kvm],[kvm_open])
252AC_CHECK_LIB([kstat],[kstat_open]) 263AC_CHECK_LIB([kstat],[kstat_open])
@@ -622,6 +633,8 @@ AC_DEFINE_UNQUOTED([HAVE_ESMTP], $esmtp, [We have libesmtp])
622# restore LIBS 633# restore LIBS
623LIBS=$SAVE_LIBS 634LIBS=$SAVE_LIBS
624 635
636
637
625# check for gettext 638# check for gettext
626AM_GNU_GETTEXT([external]) 639AM_GNU_GETTEXT([external])
627AM_GNU_GETTEXT_VERSION([0.16.1]) 640AM_GNU_GETTEXT_VERSION([0.16.1])