aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d21297969..243b4361c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -193,6 +193,16 @@ then
193 AC_MSG_ERROR([GNUnet needs libgcrypt]) 193 AC_MSG_ERROR([GNUnet needs libgcrypt])
194fi 194fi
195 195
196extra_logging=GNUNET_NO
197AC_ARG_ENABLE([logging],
198 AS_HELP_STRING([--enable-logging@<:@=value@:>@],[Enable logging calls. Possible values: yes,no,verbose,veryverbose ('yes' is the default)]),
199 [AS_IF([test "x$enableval" = "xyes"], [],
200 [test "x$enableval" = "xno"], [AC_DEFINE([GNUNET_CULL_LOGGING],[],[Define to cull all logging calls])],
201 [test "x$enableval" = "xverbose"], [extra_logging=GNUNET_YES]
202 [test "x$enableval" = "xveryverbose"], [extra_logging=\(GNUNET_YES+1\)])
203 ], [])
204AC_DEFINE_UNQUOTED([GNUNET_EXTRA_LOGGING],[$extra_logging],[1 if extra logging is enabled, 2 for very verbose extra logging, 0 otherwise])
205
196if test $build = $target 206if test $build = $target
197then 207then
198AC_MSG_CHECKING([for working HMAC]) 208AC_MSG_CHECKING([for working HMAC])