aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 26 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fb6856314..40608c5ce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -706,6 +706,27 @@ AC_SUBST(DLLDIR)
706AC_SUBST(EXT_LIB_PATH) 706AC_SUBST(EXT_LIB_PATH)
707 707
708 708
709# should 'make check' run tests?
710AC_MSG_CHECKING(whether to disable running tests)
711AC_ARG_ENABLE(testruns,
712 [AS_HELP_STRING([--enable-test-suppression],
713 [disable running tests on make check])],
714 [disable_tests_run=$enableval],
715 [disable_tests_run="no"])
716AC_MSG_RESULT($disable_test_run)
717AM_CONDITIONAL([DISABLE_TEST_RUN], [test "x$disable_tests_run" = "xyes"])
718
719# should experimental code be compiled (code that may not yet compile)?
720disable_experimental=yes
721AC_MSG_CHECKING(whether to compile experimental code)
722AC_ARG_ENABLE(experimental,
723 [AS_HELP_STRING([--enable-experimental],
724 [enable compiling experimental code])],
725 [enable_experimental=$enableval],
726 [enable_experimental="no"])
727AC_MSG_RESULT($enable_experimental)
728AM_CONDITIONAL([HAVE_EXPERIMENTAL], [test "x$enable_experimental" = "xyes"])
729
709# gcov compilation 730# gcov compilation
710use_gcov=no 731use_gcov=no
711AC_ARG_ENABLE([coverage], AS_HELP_STRING([--enable-coverage], 732AC_ARG_ENABLE([coverage], AS_HELP_STRING([--enable-coverage],
@@ -772,6 +793,11 @@ then
772 AC_MSG_NOTICE([NOTICE: libesmtp not found, monkey will not be installed.]) 793 AC_MSG_NOTICE([NOTICE: libesmtp not found, monkey will not be installed.])
773fi 794fi
774 795
796if test "x$pcap" != "x1"
797then
798 AC_MSG_NOTICE([NOTICE: libpcap not found, WiFi support will not be installed.])
799fi
800
775if test "x$openssl" != "x1" 801if test "x$openssl" != "x1"
776then 802then
777 AC_MSG_NOTICE([NOTICE: OpenSSL not found, monkey will not be installed.]) 803 AC_MSG_NOTICE([NOTICE: OpenSSL not found, monkey will not be installed.])