aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 50169797e..4ae54482d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1158,6 +1158,25 @@ AC_ARG_ENABLE([experimental],
1158AC_MSG_RESULT($enable_experimental) 1158AC_MSG_RESULT($enable_experimental)
1159AM_CONDITIONAL([HAVE_EXPERIMENTAL], [test "x$enable_experimental" = "xyes"]) 1159AM_CONDITIONAL([HAVE_EXPERIMENTAL], [test "x$enable_experimental" = "xyes"])
1160 1160
1161# should services be started by default when a peer starts? Some services may
1162# choose to never start by default and it is upto the service/module developer to
1163# decide it by having "AUTOSTART = NO" instead of "AUTOSTART = @AUTOSTART" in
1164# the service/module's conf.in file.
1165AUTOSTART="YES"
1166AC_MSG_CHECKING(whether to auto-start peer's services by default)
1167AC_ARG_ENABLE([autostart],
1168 [AS_HELP_STRING([--disable-autostart], [do not start peer's services by default])],
1169 [enable_autostart=${enableval}
1170 if test "x$enable_autostart" == "xno"
1171 then
1172 AUTOSTART="NO"
1173 fi
1174 ],
1175 [enable_autostart=yes])
1176AC_MSG_RESULT($enable_autostart)
1177#AM_CONDITIONAL([HAVE_AUTOSTART], [test "x$enable_autostart" = "xyes"])
1178AC_SUBST(AUTOSTART)
1179
1161# should memory statistics be kept (very expensive CPU-wise!) 1180# should memory statistics be kept (very expensive CPU-wise!)
1162AC_MSG_CHECKING(whether to create expensive statistics on memory use) 1181AC_MSG_CHECKING(whether to create expensive statistics on memory use)
1163AC_ARG_ENABLE([heapstats], 1182AC_ARG_ENABLE([heapstats],