aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 22 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9dd33ef8f..108fcebcf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -751,6 +751,28 @@ AC_ARG_WITH(sudo,
751AC_SUBST(SUDO_BINARY) 751AC_SUBST(SUDO_BINARY)
752 752
753 753
754# test for gnunetdns group name
755GNUNETDNS_GROUP=gnunetdns
756AC_MSG_CHECKING(for gnunetdns group name)
757AC_ARG_WITH(gnunetdns,
758 [ --with-gnunetdns=GRPNAME name for gnunetdns group],
759 [AC_MSG_RESULT("$with_gnunetdns")
760 case $with_gnunetdns in
761 no)
762 GNUNETDNS_GROUP=gnunet
763 ;;
764 yes)
765 GNUNETDNS_GROUP=gnunetdns
766 ;;
767 *)
768 GNUNETDNS_GROUP=$with_gnunetdns
769 ;;
770 esac
771 ],
772 [AC_MSG_RESULT([gnunetdns])])
773AC_SUBST(GNUNETDNS_GROUP)
774
775
754# should 'make check' run tests? 776# should 'make check' run tests?
755AC_MSG_CHECKING(whether to run tests) 777AC_MSG_CHECKING(whether to run tests)
756AC_ARG_ENABLE([testruns], 778AC_ARG_ENABLE([testruns],