aboutsummaryrefslogtreecommitdiff
path: root/contrib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/Makefile.am')
-rw-r--r--contrib/Makefile.am92
1 files changed, 46 insertions, 46 deletions
diff --git a/contrib/Makefile.am b/contrib/Makefile.am
index 40e6d3e92..8e07a5d8c 100644
--- a/contrib/Makefile.am
+++ b/contrib/Makefile.am
@@ -17,54 +17,62 @@ timeout_watchdog_SOURCES = \
17endif 17endif
18 18
19noinst_SCRIPTS = \ 19noinst_SCRIPTS = \
20 terminate.py \ 20 scripts/terminate.py \
21 pydiffer.py \ 21 scripts/pydiffer.py \
22 removetrailingwhitespace.py \ 22 scripts/removetrailingwhitespace.py \
23 gnunet_pyexpect.py \ 23 scripts/gnunet_pyexpect.py \
24 gnunet_janitor.py \ 24 scripts/gnunet_janitor.py \
25 gnunet-chk.py 25 scripts/gnunet-chk.py
26 26
27dist_pkgdata_DATA = \ 27dist_pkgdata_DATA = \
28 gns-bcd.html \ 28 gns/gns-bcd.html \
29 gns-bcd.tex \ 29 gns/gns-bcd.tex \
30 gnunet-logo.pdf \ 30 gns/def.tex \
31 gnunet-logo-color.png \ 31 gns/gns-form-fields.xml \
32 gns/gns-form.xslt \
33 branding/logo/gnunet-logo.pdf \
34 branding/logo/gnunet-logo-color.png \
35 scripts/report.sh \
32 testing_hostkeys.ecc 36 testing_hostkeys.ecc
33 37
34if MINGW 38if MINGW
35tap32_DATA = \ 39tap32_DATA = \
36 openvpn-tap32/tapw32/tap0901.sys \ 40 3rdparty/Windows/openvpn-tap32/tapw32/tap0901.sys \
37 openvpn-tap32/tapw32/tap0901.cat \ 41 3rdparty/Windows/openvpn-tap32/tapw32/tap0901.cat \
38 openvpn-tap32/tapw32/OemWin2k.inf 42 3rdparty/Windows/openvpn-tap32/tapw32/OemWin2k.inf
39 43
40tap64_DATA = \ 44tap64_DATA = \
41 openvpn-tap32/tapw64/tap0901.sys \ 45 3rdparty/Windows/openvpn-tap32/tapw64/tap0901.sys \
42 openvpn-tap32/tapw64/tap0901.cat \ 46 3rdparty/Windows/openvpn-tap32/tapw64/tap0901.cat \
43 openvpn-tap32/tapw64/OemWin2k.inf 47 3rdparty/Windows/openvpn-tap32/tapw64/OemWin2k.inf
44endif 48endif
45 49
46EXTRA_DIST = \ 50EXTRA_DIST = \
47 no_forcestart.conf \ 51 conf/colorit/colorit.conf \
48 no_autostart_above_core.conf \ 52 conf/editors/eclipse/gnunet_codingstyle.xml \
49 coverage.sh \ 53 conf/gnunet/no_forcestart.conf \
50 nssswitch.conf \ 54 conf/gnunet/no_autostart_above_core.conf \
51 report.sh \ 55 conf/nss/nssswitch.conf \
52 terminate.py.in \ 56 conf/wireshark/wireshark.lua \
53 gnunet_pyexpect.py.in \ 57 scripts/coverage.sh \
54 gnunet_janitor.py.in \ 58 scripts/terminate.py.in \
55 gnunet-chk.py.in \ 59 scripts/gnunet_pyexpect.py.in \
56 removetrailingwhitespace.py.in \ 60 scripts/gnunet_janitor.py.in \
57 pydiffer.py.in \ 61 scripts/gnunet-chk.py.in \
58 gnunet-gns-import.sh \ 62 scripts/removetrailingwhitespace.py.in \
59 openvpn-tap32/tapw32/tap0901.sys \ 63 scripts/pydiffer.py.in \
60 openvpn-tap32/tapw32/tap0901.cat \ 64 scripts/gnunet-gns-import.sh \
61 openvpn-tap32/tapw32/OemWin2k.inf \ 65 packages/nix/default.nix \
62 openvpn-tap32/tapw64/tap0901.sys \ 66 packages/nix/gnunet-dex.nix \
63 openvpn-tap32/tapw64/tap0901.cat \ 67 3rdparty/Windows/openvpn-tap32/tapw32/tap0901.sys \
64 openvpn-tap32/tapw64/OemWin2k.inf \ 68 3rdparty/Windows/openvpn-tap32/tapw32/tap0901.cat \
65 openvpn-tap32/INSTALL \ 69 3rdparty/Windows/openvpn-tap32/tapw32/OemWin2k.inf \
66 openvpn-tap32/tap32-signed-i386-2.1.zip \ 70 3rdparty/Windows/openvpn-tap32/tapw64/tap0901.sys \
67 openvpn-tap32/tap32-source-2.1.zip 71 3rdparty/Windows/openvpn-tap32/tapw64/tap0901.cat \
72 3rdparty/Windows/openvpn-tap32/tapw64/OemWin2k.inf \
73 3rdparty/Windows/openvpn-tap32/INSTALL \
74 3rdparty/Windows/openvpn-tap32/tap32-signed-i386-2.1.zip \
75 3rdparty/Windows/openvpn-tap32/tap32-source-2.1.zip
68 76
69CLEANFILES = \ 77CLEANFILES = \
70 $(noinst_SCRIPTS) 78 $(noinst_SCRIPTS)
@@ -82,21 +90,13 @@ do_subst = $(SED) -e 's,[@]PYTHON[@],$(PYTHON),g'
82# 90#
83# instead of this: 91# instead of this:
84 92
93SUFFIXES =
85SUFFIXES = .py.in .py 94SUFFIXES = .py.in .py
86 95
87.py.in.py: 96.py.in.py:
88 $(do_subst) < $< > $@ 97 $(do_subst) < $< > $@
89 chmod +x $@ 98 chmod +x $@
90 99
91# init_gnunet_redhat \
92# init_gnunet_ubuntu \
93# visualize_stats.sh \
94# gnmessage.sh \
95# junkinsert.sh \
96# junklookup.sh \
97# namespacehelper.sh
98
99
100check_PROGRAMS = \ 100check_PROGRAMS = \
101 test_gnunet_prefix 101 test_gnunet_prefix
102 102