aboutsummaryrefslogtreecommitdiff
path: root/contrib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/Makefile.am')
-rw-r--r--contrib/Makefile.am98
1 files changed, 44 insertions, 54 deletions
diff --git a/contrib/Makefile.am b/contrib/Makefile.am
index 577924fab..eec3300b9 100644
--- a/contrib/Makefile.am
+++ b/contrib/Makefile.am
@@ -5,62 +5,61 @@ tap32dir = $(pkgdatadir)/openvpn-tap32/tapw32/
5 5
6tap64dir = $(pkgdatadir)/openvpn-tap32/tapw64/ 6tap64dir = $(pkgdatadir)/openvpn-tap32/tapw64/
7 7
8noinst_PROGRAMS = \
9 timeout_watchdog
10
11if !MINGW
12timeout_watchdog_SOURCES = \
13 timeout_watchdog.c
14else
15timeout_watchdog_SOURCES = \
16 timeout_watchdog_w32.c
17endif
18
19noinst_SCRIPTS = \ 8noinst_SCRIPTS = \
20 terminate.py \ 9 scripts/terminate.py \
21 pydiffer.py \ 10 scripts/pydiffer.py \
22 gnunet_pyexpect.py \ 11 scripts/removetrailingwhitespace.py \
23 gnunet_janitor.py 12 scripts/gnunet_pyexpect.py \
13 scripts/gnunet_janitor.py \
14 scripts/gnunet-chk.py
24 15
25dist_pkgdata_DATA = \ 16dist_pkgdata_DATA = \
26 gns-bcd.html \ 17 gns/gns-bcd.html \
27 gns-bcd.tex \ 18 gns/gns-bcd.tex \
28 gnunet-logo.pdf \ 19 gns/def.tex \
29 gnunet-logo-color.png \ 20 gns/gns-form-fields.xml \
21 gns/gns-form.xslt \
22 branding/logo/gnunet-logo.pdf \
23 branding/logo/gnunet-logo-color.png \
30 testing_hostkeys.ecc 24 testing_hostkeys.ecc
31 25
32if MINGW 26if MINGW
33tap32_DATA = \ 27tap32_DATA = \
34 openvpn-tap32/tapw32/tap0901.sys \ 28 3rdparty/Windows/openvpn-tap32/tapw32/tap0901.sys \
35 openvpn-tap32/tapw32/tap0901.cat \ 29 3rdparty/Windows/openvpn-tap32/tapw32/tap0901.cat \
36 openvpn-tap32/tapw32/OemWin2k.inf 30 3rdparty/Windows/openvpn-tap32/tapw32/OemWin2k.inf
37 31
38tap64_DATA = \ 32tap64_DATA = \
39 openvpn-tap32/tapw64/tap0901.sys \ 33 3rdparty/Windows/openvpn-tap32/tapw64/tap0901.sys \
40 openvpn-tap32/tapw64/tap0901.cat \ 34 3rdparty/Windows/openvpn-tap32/tapw64/tap0901.cat \
41 openvpn-tap32/tapw64/OemWin2k.inf 35 3rdparty/Windows/openvpn-tap32/tapw64/OemWin2k.inf
42endif 36endif
43 37
44EXTRA_DIST = \ 38EXTRA_DIST = \
45 no_forcestart.conf \ 39 conf/colorit/colorit.conf \
46 no_autostart_above_core.conf \ 40 conf/editors/eclipse/gnunet_codingstyle.xml \
47 coverage.sh \ 41 conf/gnunet/no_forcestart.conf \
48 nssswitch.conf \ 42 conf/gnunet/no_autostart_above_core.conf \
49 report.sh \ 43 conf/nss/nssswitch.conf \
50 terminate.py.in \ 44 conf/wireshark/wireshark.lua \
51 gnunet_pyexpect.py.in \ 45 scripts/coverage.sh \
52 gnunet_janitor.py.in \ 46 scripts/terminate.py.in \
53 pydiffer.py.in \ 47 scripts/gnunet_pyexpect.py.in \
54 gnunet-gns-import.sh \ 48 scripts/gnunet_janitor.py.in \
55 openvpn-tap32/tapw32/tap0901.sys \ 49 scripts/gnunet-chk.py.in \
56 openvpn-tap32/tapw32/tap0901.cat \ 50 scripts/removetrailingwhitespace.py.in \
57 openvpn-tap32/tapw32/OemWin2k.inf \ 51 scripts/pydiffer.py.in \
58 openvpn-tap32/tapw64/tap0901.sys \ 52 packages/nix/default.nix \
59 openvpn-tap32/tapw64/tap0901.cat \ 53 packages/nix/gnunet-dev.nix \
60 openvpn-tap32/tapw64/OemWin2k.inf \ 54 3rdparty/Windows/openvpn-tap32/tapw32/tap0901.sys \
61 openvpn-tap32/INSTALL \ 55 3rdparty/Windows/openvpn-tap32/tapw32/tap0901.cat \
62 openvpn-tap32/tap32-signed-i386-2.1.zip \ 56 3rdparty/Windows/openvpn-tap32/tapw32/OemWin2k.inf \
63 openvpn-tap32/tap32-source-2.1.zip 57 3rdparty/Windows/openvpn-tap32/tapw64/tap0901.sys \
58 3rdparty/Windows/openvpn-tap32/tapw64/tap0901.cat \
59 3rdparty/Windows/openvpn-tap32/tapw64/OemWin2k.inf \
60 3rdparty/Windows/openvpn-tap32/INSTALL \
61 3rdparty/Windows/openvpn-tap32/tap32-signed-i386-2.1.zip \
62 3rdparty/Windows/openvpn-tap32/tap32-source-2.1.zip
64 63
65CLEANFILES = \ 64CLEANFILES = \
66 $(noinst_SCRIPTS) 65 $(noinst_SCRIPTS)
@@ -77,22 +76,12 @@ do_subst = $(SED) -e 's,[@]PYTHON[@],$(PYTHON),g'
77# chmod +x $@ 76# chmod +x $@
78# 77#
79# instead of this: 78# instead of this:
80
81SUFFIXES = .py.in .py 79SUFFIXES = .py.in .py
82 80
83.py.in.py: 81.py.in.py:
84 $(do_subst) < $< > $@ 82 $(do_subst) < $< > $@
85 chmod +x $@ 83 chmod +x $@
86 84
87# init_gnunet_redhat \
88# init_gnunet_ubuntu \
89# visualize_stats.sh \
90# gnmessage.sh \
91# junkinsert.sh \
92# junklookup.sh \
93# namespacehelper.sh
94
95
96check_PROGRAMS = \ 85check_PROGRAMS = \
97 test_gnunet_prefix 86 test_gnunet_prefix
98 87
@@ -123,6 +112,7 @@ install-data-local:
123 $(INSTALL_DATA) $$hello $(DESTDIR)$(pkghellodir)/ ; \ 112 $(INSTALL_DATA) $$hello $(DESTDIR)$(pkghellodir)/ ; \
124 fi \ 113 fi \
125 done 114 done
115 install scripts/gnunet-bugreport $(DESTDIR)$(bindir)/gnunet-bugreport
126 116
127dist-hook: 117dist-hook:
128 if test -d $(srcdir)/hellos; then \ 118 if test -d $(srcdir)/hellos; then \