aboutsummaryrefslogtreecommitdiff
path: root/contrib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/Makefile.am')
-rw-r--r--contrib/Makefile.am87
1 files changed, 34 insertions, 53 deletions
diff --git a/contrib/Makefile.am b/contrib/Makefile.am
index 6598c1520..b7507d224 100644
--- a/contrib/Makefile.am
+++ b/contrib/Makefile.am
@@ -1,31 +1,10 @@
1# This Makefile.am is in the public domain 1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include -I$(top_builddir)/src/include 2AM_CPPFLAGS = -I$(top_srcdir)/src/include -I$(top_builddir)/src/include
3 3
4SUBDIRS = scripts hellos services 4SUBDIRS = scripts services
5 5
6include Makefile.inc 6include Makefile.inc
7 7
8dist_pkgdata_DATA = \
9 gns/gns-form.xslt \
10 gns/gns-bcd.html \
11 gns/def.tex \
12 gns/bootstrap.min.css \
13 gns/gns-form-fields.xml \
14 gns/gns-bcd.tex \
15 fcfsd/fcfsd-index.html \
16 fcfsd/fcfsd-forbidden.html \
17 fcfsd/fcfsd-notfound.html \
18 branding/logo/gnunet-logo.png \
19 branding/logo/lynXified-amirouche-v3.svg \
20 branding/logo/gnunet-logo-dark-text.svg \
21 branding/logo/gnunet-logo-color.png \
22 branding/logo/lynXified-amirouche-anonymous-v3.png \
23 branding/logo/gnunet-logo-dark-only-text.svg \
24 branding/logo/gnunet-logo-big.png \
25 branding/logo/gnunet-logo.pdf \
26 testing_hostkeys.ecc \
27 $(BUILDCOMMON_SHLIB_FILES)
28
29INITD_FILES = \ 8INITD_FILES = \
30 services/systemd/gnunet-user.service \ 9 services/systemd/gnunet-user.service \
31 services/systemd/sysusers-gnunet.conf \ 10 services/systemd/sysusers-gnunet.conf \
@@ -34,9 +13,10 @@ INITD_FILES = \
34 services/openrc/gnunet.initd 13 services/openrc/gnunet.initd
35 14
36PACKAGES_FILES = \ 15PACKAGES_FILES = \
37 packages/guix/guix-env-py2.scm \ 16 packages/fedora/10-dns2gns.sh \
38 packages/guix/guix-env-gillmann.scm \ 17 packages/fedora/gnunet-system.conf \
39 packages/guix/notest-guix-env.scm \ 18 packages/fedora/gnunet.service \
19 packages/fedora/gnunet-user.service \
40 packages/alpine/gnunet-gtk/APKBUILD \ 20 packages/alpine/gnunet-gtk/APKBUILD \
41 packages/alpine/gnurl/APKBUILD \ 21 packages/alpine/gnurl/APKBUILD \
42 packages/alpine/gnunet/gnunet-user-services.initd \ 22 packages/alpine/gnunet/gnunet-user-services.initd \
@@ -49,16 +29,34 @@ PACKAGES_FILES = \
49 packages/alpine/gnunet/gnunet.pre-install \ 29 packages/alpine/gnunet/gnunet.pre-install \
50 packages/alpine/gnunet/gnunet-system-services.initd \ 30 packages/alpine/gnunet/gnunet-system-services.initd \
51 packages/alpine/gnunet/gnunet-gns-proxy.initd \ 31 packages/alpine/gnunet/gnunet-gns-proxy.initd \
32 packages/arch/gnunet-git/gnunet.install \
33 packages/arch/gnunet-git/gnunet-system.service \
34 packages/arch/gnunet-git/gnunet.sysusers \
35 packages/arch/gnunet-git/gnunet.tmpfiles \
36 packages/arch/gnunet-git/gnunet-user.conf \
37 packages/arch/gnunet-git/gnunet-user.service \
38 packages/arch/gnunet-git/PKGBUILD \
39 packages/arch/gnunet-git/.SRCINFO \
40 packages/arch/gnunet/gnunet.install \
41 packages/arch/gnunet/gnunet-system.service \
42 packages/arch/gnunet/gnunet.sysusers \
43 packages/arch/gnunet/gnunet.tmpfiles \
44 packages/arch/gnunet/gnunet-user.conf \
45 packages/arch/gnunet/gnunet-user.service \
46 packages/arch/gnunet/PKGBUILD \
47 packages/arch/gnunet/.SRCINFO \
48 packages/guix/guix-env-py2.scm \
49 packages/guix/guix-env-gillmann.scm \
50 packages/guix/notest-guix-env.scm \
51 packages/homebrew/gnunet.rb \
52 packages/nix/gnunet-dev.nix \ 52 packages/nix/gnunet-dev.nix \
53 packages/nix/default.nix \ 53 packages/nix/default.nix
54 packages/homebrew/gnunet.rb
55 54
56EXTRA_DIST = \ 55EXTRA_DIST = \
57 sounds/vonlynX-bdbAm-lo.wav \ 56 sounds/vonlynX-bdbAm-lo.wav \
58 sounds/vonlynX-bdbG9-lo.wav \ 57 sounds/vonlynX-bdbG9-lo.wav \
59 sounds/vonlynX-ringtones.txt \ 58 sounds/vonlynX-ringtones.txt \
60 A-Z.ecc \ 59 A-Z.ecc \
61 xdg-scheme-handler/gnunet-uri.desktop \
62 xdg-scheme-handler/README.md \ 60 xdg-scheme-handler/README.md \
63 apparmor/gnunet-daemon-testbed-blacklist \ 61 apparmor/gnunet-daemon-testbed-blacklist \
64 apparmor/gnunet-service-identity \ 62 apparmor/gnunet-service-identity \
@@ -145,7 +143,6 @@ EXTRA_DIST = \
145 apparmor/gnunet-namestore-gtk \ 143 apparmor/gnunet-namestore-gtk \
146 apparmor/gnunet-service-testbed-logger \ 144 apparmor/gnunet-service-testbed-logger \
147 apparmor/gnunet-peerstore \ 145 apparmor/gnunet-peerstore \
148 apparmor/gnunet-namestore-fcfsd \
149 apparmor/gnunet-core \ 146 apparmor/gnunet-core \
150 apparmor/gnunet-gns-import.sh \ 147 apparmor/gnunet-gns-import.sh \
151 apparmor/gnunet-gns-proxy \ 148 apparmor/gnunet-gns-proxy \
@@ -184,38 +181,19 @@ EXTRA_DIST = \
184 conf/gnunet/no_forcestart.conf \ 181 conf/gnunet/no_forcestart.conf \
185 conf/colorit/colorit.conf \ 182 conf/colorit/colorit.conf \
186 conf/nss/nssswitch.conf \ 183 conf/nss/nssswitch.conf \
187 testbed_infiniband_results/6000_connections_20000_peers.txt \
188 testbed_infiniband_results/6000_connections_10000_peers_20_poc.txt \
189 testbed_infiniband_results/6000_connections_10000_peers_30_poc.txt \
190 testbed_infiniband_results/6000_connections_40000_peers.txt \
191 testbed_infiniband_results/6000_connections_60000_peers_5_poc.txt \
192 testbed_infiniband_results/30000_connections_90000_peers_30_poc.txt \
193 testbed_infiniband_results/6000_connections_80000_peers_20_poc.txt \
194 testbed_infiniband_results/6000_connections_80000_peers_5_poc.txt \
195 testbed_infiniband_results/6000_connections_10000_peers_100_poc.txt \
196 testbed_infiniband_results/6000_connections_60000_peers.txt \
197 testbed_configs/testbed_cluster.conf \ 184 testbed_configs/testbed_cluster.conf \
198 testbed_configs/testbed_infiniband.conf \
199 testbed_configs/regex_profiler_infiniband.conf \
200 testbed_configs/testbed_supermuc.conf \ 185 testbed_configs/testbed_supermuc.conf \
201 guix.README \ 186 packages/guix/guix.README \
202 web/log.php \ 187 web/log.php \
203 ci/docker/docker-entrypoint.sh \
204 ci/docker/Dockerfile \
205 ci/buildbot/buildbot-update.sh \ 188 ci/buildbot/buildbot-update.sh \
206 ci/buildbot/ssh-keys \ 189 ci/buildbot/ssh-keys \
207 ci/buildbot/ssh-config \ 190 ci/buildbot/ssh-config \
208 docker/docker-entrypoint.sh \ 191 docker/docker-entrypoint.sh \
209 docker/Dockerfile \ 192 docker/Dockerfile \
210 docker/README.md \ 193 docker/README.md \
211 docker/gnunet.conf \
212 nse/experiments/infiniband.conf \
213 benchmark/collect.awk \ 194 benchmark/collect.awk \
214 gnunet_infrastructure/handbook_pull.sh \ 195 packages/guix/guix.scm \
215 guix.scm \
216 indent_pre-commit \
217 Makefile.inc \ 196 Makefile.inc \
218 gnunet.m4 \
219 vagrant/Vagrantfile \ 197 vagrant/Vagrantfile \
220 vagrant/bootstrap.ubuntu.sh \ 198 vagrant/bootstrap.ubuntu.sh \
221 privacy-sensitive-symbols.mspec \ 199 privacy-sensitive-symbols.mspec \
@@ -225,8 +203,7 @@ EXTRA_DIST = \
225 patches/lrn-indent.diff \ 203 patches/lrn-indent.diff \
226 test_gnunet_prefix.c \ 204 test_gnunet_prefix.c \
227 $(PACKAGES_FILES) \ 205 $(PACKAGES_FILES) \
228 $(INITD_FILES) \ 206 $(INITD_FILES)
229 $(BUILD_COMMON_FILES)
230 207
231check_PROGRAMS = \ 208check_PROGRAMS = \
232 test_gnunet_prefix 209 test_gnunet_prefix
@@ -250,7 +227,11 @@ test_gnunet_prefix_LDADD = \
250 $(LIBLTDL) -lunistring $(XLIB) 227 $(LIBLTDL) -lunistring $(XLIB)
251 228
252aclocaldir = $(datadir)/aclocal 229aclocaldir = $(datadir)/aclocal
253aclocal_DATA = \ 230dist_aclocal_DATA = \
254 gnunet.m4 231 gnunet.m4
255 232
233xdgdeentrydir = $(datadir)/applications
234dist_xdgdeentry_DATA = \
235 xdg-scheme-handler/gnunet-uri.desktop
236
256## EOF 237## EOF