aboutsummaryrefslogtreecommitdiff
path: root/contrib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/Makefile.am')
-rw-r--r--contrib/Makefile.am88
1 files changed, 33 insertions, 55 deletions
diff --git a/contrib/Makefile.am b/contrib/Makefile.am
index e0370d3c9..b7507d224 100644
--- a/contrib/Makefile.am
+++ b/contrib/Makefile.am
@@ -1,40 +1,10 @@
1# This Makefile.am is in the public domain 1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include -I$(top_builddir)/src/include 2AM_CPPFLAGS = -I$(top_srcdir)/src/include -I$(top_builddir)/src/include
3 3
4SUBDIRS = scripts hellos services 4SUBDIRS = scripts services
5 5
6include Makefile.inc 6include Makefile.inc
7 7
8dist_pkgdata_DATA = \
9 gns/def.tex \
10 gns/gns-bcd.html \
11 gns/gns-bcd.tex \
12 gns/gns-bcd-forbidden.html \
13 gns/gns-bcd-internal-error.html \
14 gns/gns-bcd-invalid-key.html \
15 gns/gns-bcd-not-found.html \
16 gns/gns-bcd-png.tex \
17 gns/gns-bcd-simple.html \
18 gns/gns-bcd-simple.tex \
19 fcfsd/fcfsd-index.html \
20 fcfsd/fcfsd-forbidden.html \
21 fcfsd/fcfsd-notfound.html \
22 branding/logo/gnunet-logo.png \
23 branding/logo/lynXified-amirouche-v3.svg \
24 branding/logo/gnunet-logo-dark-text.svg \
25 branding/logo/gnunet-logo-color.png \
26 branding/logo/lynXified-amirouche-anonymous-v3.png \
27 branding/logo/gnunet-logo-dark-only-text.svg \
28 branding/logo/gnunet-logo-big.png \
29 branding/logo/gnunet-logo.pdf \
30 testing_hostkeys.ecc \
31 netjail/netjail_core.sh \
32 netjail/netjail_exec.sh \
33 netjail/netjail_start.sh \
34 netjail/netjail_stop.sh \
35 netjail/topo.sh \
36 $(BUILDCOMMON_SHLIB_FILES)
37
38INITD_FILES = \ 8INITD_FILES = \
39 services/systemd/gnunet-user.service \ 9 services/systemd/gnunet-user.service \
40 services/systemd/sysusers-gnunet.conf \ 10 services/systemd/sysusers-gnunet.conf \
@@ -43,9 +13,10 @@ INITD_FILES = \
43 services/openrc/gnunet.initd 13 services/openrc/gnunet.initd
44 14
45PACKAGES_FILES = \ 15PACKAGES_FILES = \
46 packages/guix/guix-env-py2.scm \ 16 packages/fedora/10-dns2gns.sh \
47 packages/guix/guix-env-gillmann.scm \ 17 packages/fedora/gnunet-system.conf \
48 packages/guix/notest-guix-env.scm \ 18 packages/fedora/gnunet.service \
19 packages/fedora/gnunet-user.service \
49 packages/alpine/gnunet-gtk/APKBUILD \ 20 packages/alpine/gnunet-gtk/APKBUILD \
50 packages/alpine/gnurl/APKBUILD \ 21 packages/alpine/gnurl/APKBUILD \
51 packages/alpine/gnunet/gnunet-user-services.initd \ 22 packages/alpine/gnunet/gnunet-user-services.initd \
@@ -58,16 +29,34 @@ PACKAGES_FILES = \
58 packages/alpine/gnunet/gnunet.pre-install \ 29 packages/alpine/gnunet/gnunet.pre-install \
59 packages/alpine/gnunet/gnunet-system-services.initd \ 30 packages/alpine/gnunet/gnunet-system-services.initd \
60 packages/alpine/gnunet/gnunet-gns-proxy.initd \ 31 packages/alpine/gnunet/gnunet-gns-proxy.initd \
32 packages/arch/gnunet-git/gnunet.install \
33 packages/arch/gnunet-git/gnunet-system.service \
34 packages/arch/gnunet-git/gnunet.sysusers \
35 packages/arch/gnunet-git/gnunet.tmpfiles \
36 packages/arch/gnunet-git/gnunet-user.conf \
37 packages/arch/gnunet-git/gnunet-user.service \
38 packages/arch/gnunet-git/PKGBUILD \
39 packages/arch/gnunet-git/.SRCINFO \
40 packages/arch/gnunet/gnunet.install \
41 packages/arch/gnunet/gnunet-system.service \
42 packages/arch/gnunet/gnunet.sysusers \
43 packages/arch/gnunet/gnunet.tmpfiles \
44 packages/arch/gnunet/gnunet-user.conf \
45 packages/arch/gnunet/gnunet-user.service \
46 packages/arch/gnunet/PKGBUILD \
47 packages/arch/gnunet/.SRCINFO \
48 packages/guix/guix-env-py2.scm \
49 packages/guix/guix-env-gillmann.scm \
50 packages/guix/notest-guix-env.scm \
51 packages/homebrew/gnunet.rb \
61 packages/nix/gnunet-dev.nix \ 52 packages/nix/gnunet-dev.nix \
62 packages/nix/default.nix \ 53 packages/nix/default.nix
63 packages/homebrew/gnunet.rb
64 54
65EXTRA_DIST = \ 55EXTRA_DIST = \
66 sounds/vonlynX-bdbAm-lo.wav \ 56 sounds/vonlynX-bdbAm-lo.wav \
67 sounds/vonlynX-bdbG9-lo.wav \ 57 sounds/vonlynX-bdbG9-lo.wav \
68 sounds/vonlynX-ringtones.txt \ 58 sounds/vonlynX-ringtones.txt \
69 A-Z.ecc \ 59 A-Z.ecc \
70 xdg-scheme-handler/gnunet-uri.desktop \
71 xdg-scheme-handler/README.md \ 60 xdg-scheme-handler/README.md \
72 apparmor/gnunet-daemon-testbed-blacklist \ 61 apparmor/gnunet-daemon-testbed-blacklist \
73 apparmor/gnunet-service-identity \ 62 apparmor/gnunet-service-identity \
@@ -154,7 +143,6 @@ EXTRA_DIST = \
154 apparmor/gnunet-namestore-gtk \ 143 apparmor/gnunet-namestore-gtk \
155 apparmor/gnunet-service-testbed-logger \ 144 apparmor/gnunet-service-testbed-logger \
156 apparmor/gnunet-peerstore \ 145 apparmor/gnunet-peerstore \
157 apparmor/gnunet-namestore-fcfsd \
158 apparmor/gnunet-core \ 146 apparmor/gnunet-core \
159 apparmor/gnunet-gns-import.sh \ 147 apparmor/gnunet-gns-import.sh \
160 apparmor/gnunet-gns-proxy \ 148 apparmor/gnunet-gns-proxy \
@@ -195,23 +183,17 @@ EXTRA_DIST = \
195 conf/nss/nssswitch.conf \ 183 conf/nss/nssswitch.conf \
196 testbed_configs/testbed_cluster.conf \ 184 testbed_configs/testbed_cluster.conf \
197 testbed_configs/testbed_supermuc.conf \ 185 testbed_configs/testbed_supermuc.conf \
198 guix.README \ 186 packages/guix/guix.README \
199 web/log.php \ 187 web/log.php \
200 ci/docker/docker-entrypoint.sh \
201 ci/docker/Dockerfile \
202 ci/buildbot/buildbot-update.sh \ 188 ci/buildbot/buildbot-update.sh \
203 ci/buildbot/ssh-keys \ 189 ci/buildbot/ssh-keys \
204 ci/buildbot/ssh-config \ 190 ci/buildbot/ssh-config \
205 docker/docker-entrypoint.sh \ 191 docker/docker-entrypoint.sh \
206 docker/Dockerfile \ 192 docker/Dockerfile \
207 docker/README.md \ 193 docker/README.md \
208 docker/gnunet.conf \
209 benchmark/collect.awk \ 194 benchmark/collect.awk \
210 gnunet_infrastructure/handbook_pull.sh \ 195 packages/guix/guix.scm \
211 guix.scm \
212 indent_pre-commit \
213 Makefile.inc \ 196 Makefile.inc \
214 gnunet.m4 \
215 vagrant/Vagrantfile \ 197 vagrant/Vagrantfile \
216 vagrant/bootstrap.ubuntu.sh \ 198 vagrant/bootstrap.ubuntu.sh \
217 privacy-sensitive-symbols.mspec \ 199 privacy-sensitive-symbols.mspec \
@@ -221,8 +203,7 @@ EXTRA_DIST = \
221 patches/lrn-indent.diff \ 203 patches/lrn-indent.diff \
222 test_gnunet_prefix.c \ 204 test_gnunet_prefix.c \
223 $(PACKAGES_FILES) \ 205 $(PACKAGES_FILES) \
224 $(INITD_FILES) \ 206 $(INITD_FILES)
225 $(BUILD_COMMON_FILES)
226 207
227check_PROGRAMS = \ 208check_PROGRAMS = \
228 test_gnunet_prefix 209 test_gnunet_prefix
@@ -246,14 +227,11 @@ test_gnunet_prefix_LDADD = \
246 $(LIBLTDL) -lunistring $(XLIB) 227 $(LIBLTDL) -lunistring $(XLIB)
247 228
248aclocaldir = $(datadir)/aclocal 229aclocaldir = $(datadir)/aclocal
249aclocal_DATA = \ 230dist_aclocal_DATA = \
250 gnunet.m4 231 gnunet.m4
251 232
252install-data-hook: 233xdgdeentrydir = $(datadir)/applications
253 chmod o+x '$(DESTDIR)$(pkgdatadir)/netjail_core.sh' 234dist_xdgdeentry_DATA = \
254 chmod o+x '$(DESTDIR)$(pkgdatadir)/netjail_start.sh' 235 xdg-scheme-handler/gnunet-uri.desktop
255 chmod o+x '$(DESTDIR)$(pkgdatadir)/netjail_stop.sh'
256 chmod o+x '$(DESTDIR)$(pkgdatadir)/netjail_exec.sh'
257 chmod o+x '$(DESTDIR)$(pkgdatadir)/topo.sh'
258 236
259## EOF 237## EOF