aboutsummaryrefslogtreecommitdiff
path: root/contrib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/Makefile.am')
-rw-r--r--contrib/Makefile.am85
1 files changed, 32 insertions, 53 deletions
diff --git a/contrib/Makefile.am b/contrib/Makefile.am
index e05e9caf9..b7507d224 100644
--- a/contrib/Makefile.am
+++ b/contrib/Makefile.am
@@ -1,39 +1,10 @@
1# This Makefile.am is in the public domain 1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include -I$(top_builddir)/src/include 2AM_CPPFLAGS = -I$(top_srcdir)/src/include -I$(top_builddir)/src/include
3 3
4SUBDIRS = scripts hellos services 4SUBDIRS = scripts services
5 5
6include Makefile.inc 6include Makefile.inc
7 7
8dist_pkgdata_DATA = \
9 gns/def.tex \
10 gns/gns-bcd.html \
11 gns/gns-bcd.tex \
12 gns/gns-bcd-forbidden.html \
13 gns/gns-bcd-internal-error.html \
14 gns/gns-bcd-invalid-key.html \
15 gns/gns-bcd-not-found.html \
16 gns/gns-bcd-png.tex \
17 gns/gns-bcd-simple.html \
18 gns/gns-bcd-simple.tex \
19 fcfsd/fcfsd-index.html \
20 fcfsd/fcfsd-forbidden.html \
21 fcfsd/fcfsd-notfound.html \
22 branding/logo/gnunet-logo.png \
23 branding/logo/lynXified-amirouche-v3.svg \
24 branding/logo/gnunet-logo-dark-text.svg \
25 branding/logo/gnunet-logo-color.png \
26 branding/logo/lynXified-amirouche-anonymous-v3.png \
27 branding/logo/gnunet-logo-dark-only-text.svg \
28 branding/logo/gnunet-logo-big.png \
29 branding/logo/gnunet-logo.pdf \
30 testing_hostkeys.ecc \
31 netjail/netjail_core.sh \
32 netjail/netjail_exec.sh \
33 netjail/netjail_start.sh \
34 netjail/netjail_stop.sh \
35 netjail/topo.sh
36
37INITD_FILES = \ 8INITD_FILES = \
38 services/systemd/gnunet-user.service \ 9 services/systemd/gnunet-user.service \
39 services/systemd/sysusers-gnunet.conf \ 10 services/systemd/sysusers-gnunet.conf \
@@ -42,9 +13,10 @@ INITD_FILES = \
42 services/openrc/gnunet.initd 13 services/openrc/gnunet.initd
43 14
44PACKAGES_FILES = \ 15PACKAGES_FILES = \
45 packages/guix/guix-env-py2.scm \ 16 packages/fedora/10-dns2gns.sh \
46 packages/guix/guix-env-gillmann.scm \ 17 packages/fedora/gnunet-system.conf \
47 packages/guix/notest-guix-env.scm \ 18 packages/fedora/gnunet.service \
19 packages/fedora/gnunet-user.service \
48 packages/alpine/gnunet-gtk/APKBUILD \ 20 packages/alpine/gnunet-gtk/APKBUILD \
49 packages/alpine/gnurl/APKBUILD \ 21 packages/alpine/gnurl/APKBUILD \
50 packages/alpine/gnunet/gnunet-user-services.initd \ 22 packages/alpine/gnunet/gnunet-user-services.initd \
@@ -57,16 +29,34 @@ PACKAGES_FILES = \
57 packages/alpine/gnunet/gnunet.pre-install \ 29 packages/alpine/gnunet/gnunet.pre-install \
58 packages/alpine/gnunet/gnunet-system-services.initd \ 30 packages/alpine/gnunet/gnunet-system-services.initd \
59 packages/alpine/gnunet/gnunet-gns-proxy.initd \ 31 packages/alpine/gnunet/gnunet-gns-proxy.initd \
32 packages/arch/gnunet-git/gnunet.install \
33 packages/arch/gnunet-git/gnunet-system.service \
34 packages/arch/gnunet-git/gnunet.sysusers \
35 packages/arch/gnunet-git/gnunet.tmpfiles \
36 packages/arch/gnunet-git/gnunet-user.conf \
37 packages/arch/gnunet-git/gnunet-user.service \
38 packages/arch/gnunet-git/PKGBUILD \
39 packages/arch/gnunet-git/.SRCINFO \
40 packages/arch/gnunet/gnunet.install \
41 packages/arch/gnunet/gnunet-system.service \
42 packages/arch/gnunet/gnunet.sysusers \
43 packages/arch/gnunet/gnunet.tmpfiles \
44 packages/arch/gnunet/gnunet-user.conf \
45 packages/arch/gnunet/gnunet-user.service \
46 packages/arch/gnunet/PKGBUILD \
47 packages/arch/gnunet/.SRCINFO \
48 packages/guix/guix-env-py2.scm \
49 packages/guix/guix-env-gillmann.scm \
50 packages/guix/notest-guix-env.scm \
51 packages/homebrew/gnunet.rb \
60 packages/nix/gnunet-dev.nix \ 52 packages/nix/gnunet-dev.nix \
61 packages/nix/default.nix \ 53 packages/nix/default.nix
62 packages/homebrew/gnunet.rb
63 54
64EXTRA_DIST = \ 55EXTRA_DIST = \
65 sounds/vonlynX-bdbAm-lo.wav \ 56 sounds/vonlynX-bdbAm-lo.wav \
66 sounds/vonlynX-bdbG9-lo.wav \ 57 sounds/vonlynX-bdbG9-lo.wav \
67 sounds/vonlynX-ringtones.txt \ 58 sounds/vonlynX-ringtones.txt \
68 A-Z.ecc \ 59 A-Z.ecc \
69 xdg-scheme-handler/gnunet-uri.desktop \
70 xdg-scheme-handler/README.md \ 60 xdg-scheme-handler/README.md \
71 apparmor/gnunet-daemon-testbed-blacklist \ 61 apparmor/gnunet-daemon-testbed-blacklist \
72 apparmor/gnunet-service-identity \ 62 apparmor/gnunet-service-identity \
@@ -153,7 +143,6 @@ EXTRA_DIST = \
153 apparmor/gnunet-namestore-gtk \ 143 apparmor/gnunet-namestore-gtk \
154 apparmor/gnunet-service-testbed-logger \ 144 apparmor/gnunet-service-testbed-logger \
155 apparmor/gnunet-peerstore \ 145 apparmor/gnunet-peerstore \
156 apparmor/gnunet-namestore-fcfsd \
157 apparmor/gnunet-core \ 146 apparmor/gnunet-core \
158 apparmor/gnunet-gns-import.sh \ 147 apparmor/gnunet-gns-import.sh \
159 apparmor/gnunet-gns-proxy \ 148 apparmor/gnunet-gns-proxy \
@@ -194,24 +183,17 @@ EXTRA_DIST = \
194 conf/nss/nssswitch.conf \ 183 conf/nss/nssswitch.conf \
195 testbed_configs/testbed_cluster.conf \ 184 testbed_configs/testbed_cluster.conf \
196 testbed_configs/testbed_supermuc.conf \ 185 testbed_configs/testbed_supermuc.conf \
197 guix.README \ 186 packages/guix/guix.README \
198 web/log.php \ 187 web/log.php \
199 ci/docker/docker-entrypoint.sh \
200 ci/docker/Dockerfile \
201 ci/buildbot/buildbot-update.sh \ 188 ci/buildbot/buildbot-update.sh \
202 ci/buildbot/ssh-keys \ 189 ci/buildbot/ssh-keys \
203 ci/buildbot/ssh-config \ 190 ci/buildbot/ssh-config \
204 docker/docker-entrypoint.sh \ 191 docker/docker-entrypoint.sh \
205 docker/Dockerfile \ 192 docker/Dockerfile \
206 docker/README.md \ 193 docker/README.md \
207 docker/gnunet.conf \
208 benchmark/collect.awk \ 194 benchmark/collect.awk \
209 get_version.sh \ 195 packages/guix/guix.scm \
210 gnunet_infrastructure/handbook_pull.sh \
211 guix.scm \
212 indent_pre-commit \
213 Makefile.inc \ 196 Makefile.inc \
214 gnunet.m4 \
215 vagrant/Vagrantfile \ 197 vagrant/Vagrantfile \
216 vagrant/bootstrap.ubuntu.sh \ 198 vagrant/bootstrap.ubuntu.sh \
217 privacy-sensitive-symbols.mspec \ 199 privacy-sensitive-symbols.mspec \
@@ -245,14 +227,11 @@ test_gnunet_prefix_LDADD = \
245 $(LIBLTDL) -lunistring $(XLIB) 227 $(LIBLTDL) -lunistring $(XLIB)
246 228
247aclocaldir = $(datadir)/aclocal 229aclocaldir = $(datadir)/aclocal
248aclocal_DATA = \ 230dist_aclocal_DATA = \
249 gnunet.m4 231 gnunet.m4
250 232
251install-data-hook: 233xdgdeentrydir = $(datadir)/applications
252 chmod o+x '$(DESTDIR)$(pkgdatadir)/netjail_core.sh' 234dist_xdgdeentry_DATA = \
253 chmod o+x '$(DESTDIR)$(pkgdatadir)/netjail_start.sh' 235 xdg-scheme-handler/gnunet-uri.desktop
254 chmod o+x '$(DESTDIR)$(pkgdatadir)/netjail_stop.sh'
255 chmod o+x '$(DESTDIR)$(pkgdatadir)/netjail_exec.sh'
256 chmod o+x '$(DESTDIR)$(pkgdatadir)/topo.sh'
257 236
258## EOF 237## EOF