aboutsummaryrefslogtreecommitdiff
path: root/contrib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/Makefile.am')
-rw-r--r--contrib/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/contrib/Makefile.am b/contrib/Makefile.am
index 5371730cc..e4b92bb2e 100644
--- a/contrib/Makefile.am
+++ b/contrib/Makefile.am
@@ -6,6 +6,9 @@ timeout_watchdog_SOURCES = \
6 timeout_watchdog.c 6 timeout_watchdog.c
7endif 7endif
8 8
9noinst_SCRIPTS = \
10 gnunet_pyexpect/gnunet_pyexpect.py
11
9dist_pkgdata_DATA = \ 12dist_pkgdata_DATA = \
10 gnunet-logo-color.png \ 13 gnunet-logo-color.png \
11 defaults.conf 14 defaults.conf
@@ -14,7 +17,17 @@ EXTRA_DIST = \
14 coverage.sh \ 17 coverage.sh \
15 hostlist.cgi \ 18 hostlist.cgi \
16 hostlist.php \ 19 hostlist.php \
17 report.sh 20 report.sh \
21 gnunet_pyexpect/__init__.py \
22 gnunet_pyexpect/gnunet_pyexpect.py.in
23
24do_subst = $(SED) -e 's,[@]PYTHON[@],$(PYTHON),g'
25
26gnunet_pyexpect/gnunet_pyexpect.py: gnunet_pyexpect/gnunet_pyexpect.py.in Makefile
27 $(do_subst) < $(srcdir)/gnunet_pyexpect/gnunet_pyexpect.py.in > gnunet_pyexpect/gnunet_pyexpect.py
28 chmod +x gnunet_pyexpect/gnunet_pyexpect.py
29 chmod +x gnunet_pyexpect/__init__.py
30
18 31
19# init_gnunet_redhat \ 32# init_gnunet_redhat \
20# init_gnunet_ubuntu \ 33# init_gnunet_ubuntu \