aboutsummaryrefslogtreecommitdiff
path: root/contrib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/Makefile.am')
-rw-r--r--contrib/Makefile.am37
1 files changed, 1 insertions, 36 deletions
diff --git a/contrib/Makefile.am b/contrib/Makefile.am
index 49aa36dfd..ff1d1fbbb 100644
--- a/contrib/Makefile.am
+++ b/contrib/Makefile.am
@@ -5,13 +5,7 @@ tap32dir = $(pkgdatadir)/openvpn-tap32/tapw32/
5 5
6tap64dir = $(pkgdatadir)/openvpn-tap32/tapw64/ 6tap64dir = $(pkgdatadir)/openvpn-tap32/tapw64/
7 7
8noinst_SCRIPTS = \ 8SUBDIRS = scripts
9 scripts/terminate.py \
10 scripts/pydiffer.py \
11 scripts/removetrailingwhitespace.py \
12 scripts/gnunet_pyexpect.py \
13 scripts/gnunet_janitor.py \
14 scripts/gnunet-chk.py
15 9
16dist_pkgdata_DATA = \ 10dist_pkgdata_DATA = \
17 gns/gns-bcd.html \ 11 gns/gns-bcd.html \
@@ -46,14 +40,6 @@ EXTRA_DIST = \
46 conf/gnunet/no_autostart_above_core.conf \ 40 conf/gnunet/no_autostart_above_core.conf \
47 conf/nss/nssswitch.conf \ 41 conf/nss/nssswitch.conf \
48 conf/wireshark/wireshark.lua \ 42 conf/wireshark/wireshark.lua \
49 scripts/coverage.sh \
50 scripts/terminate.py.in \
51 scripts/gnunet_pyexpect.py.in \
52 scripts/gnunet_janitor.py.in \
53 scripts/gnunet-chk.py.in \
54 scripts/gnunet-bugreport \
55 scripts/removetrailingwhitespace.py.in \
56 scripts/pydiffer.py.in \
57 packages/nix/default.nix \ 43 packages/nix/default.nix \
58 packages/nix/gnunet-dev.nix \ 44 packages/nix/gnunet-dev.nix \
59 3rdparty/Windows/openvpn-tap32/tapw32/tap0901.sys \ 45 3rdparty/Windows/openvpn-tap32/tapw32/tap0901.sys \
@@ -67,27 +53,6 @@ EXTRA_DIST = \
67 3rdparty/Windows/openvpn-tap32/tap32-source-2.1.zip \ 53 3rdparty/Windows/openvpn-tap32/tap32-source-2.1.zip \
68 $(INITD_FILES) 54 $(INITD_FILES)
69 55
70CLEANFILES = \
71 $(noinst_SCRIPTS)
72
73do_subst = $(SED) -e 's,[@]PYTHON[@],$(PYTHON),g'
74
75# Use SUFFIX Extension rules, they are more portable for every
76# implementation of 'make'.
77# You'll also run into the "'%' is a GNU make extension warning"
78# if you use this:
79#
80#%.py: %.py.in Makefile
81# $(do_subst) < $< > $@
82# chmod +x $@
83#
84# instead of this:
85SUFFIXES = .py.in .py
86
87.py.in.py:
88 $(do_subst) < $< > $@
89 chmod +x $@
90
91check_PROGRAMS = \ 56check_PROGRAMS = \
92 test_gnunet_prefix 57 test_gnunet_prefix
93 58