aboutsummaryrefslogtreecommitdiff
path: root/contrib/alpine/gnurl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/alpine/gnurl/APKBUILD')
-rw-r--r--contrib/alpine/gnurl/APKBUILD69
1 files changed, 31 insertions, 38 deletions
diff --git a/contrib/alpine/gnurl/APKBUILD b/contrib/alpine/gnurl/APKBUILD
index f8ff73a91..f14a9bd97 100644
--- a/contrib/alpine/gnurl/APKBUILD
+++ b/contrib/alpine/gnurl/APKBUILD
@@ -5,72 +5,65 @@ pkgver=7.65.3
5pkgrel=0 5pkgrel=0
6pkgdesc="curl with only HTTP/HTTPS support and GnuTLS" 6pkgdesc="curl with only HTTP/HTTPS support and GnuTLS"
7url="https://gnunet.org/en/gnurl.html" 7url="https://gnunet.org/en/gnurl.html"
8giturl="git://git.taler.net/gnurl.git"
9arch="all" 8arch="all"
10license="MIT" 9license="MIT"
11depends="ca-certificates gnutls libidn2 zlib" 10depends="ca-certificates gnutls libidn2 zlib"
12depends_dev="gnutls-dev libidn2-dev zlib-dev" 11depends_dev="gnutls-dev libidn2-dev zlib-dev"
13makedepends="$depends_dev autoconf automake libtool perl pkgconf python3" 12makedepends="$depends_dev autoconf automake libtool perl pkgconf python3"
14subpackages="$pkgname-dbg $pkgname-dev $pkgname-doc libgnurl" 13subpackages="$pkgname-dbg $pkgname-dev $pkgname-doc libgnurl"
15source="https://ftp.gnu.org/gnu/gnunet/$pkgname-$pkgver.tar.gz" 14source="https://ftp.gnu.org/gnu/gnunet/gnurl-$pkgver.tar.gz"
16builddir="$srcdir/$pkgname-$pkgver"
17 15
18prepare() { 16prepare() {
19 default_prepare 17 default_prepare
20 cd "$builddir"
21 autoreconf -vfi 18 autoreconf -vfi
22} 19}
23 20
24build() { 21build() {
25 cd "$builddir" 22 ./configure \
26
27 ./configure \
28 --build=$CBUILD \ 23 --build=$CBUILD \
29 --host=$CHOST \ 24 --host=$CHOST \
30 --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt \ 25 --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt \
31 --prefix=/usr \ 26 --prefix=/usr \
27 --disable-static \
32 --enable-ipv6 \ 28 --enable-ipv6 \
33 --with-gnutls \ 29 --with-gnutls \
34 --with-libidn2 \ 30 --with-libidn2 \
35 --without-libpsl \ 31 --without-libpsl \
36 --without-libssh2 \ 32 --without-libssh2 \
37 --without-libmetalink \ 33 --without-libmetalink \
38 --without-winidn \ 34 --without-winidn \
39 --without-librtmp \ 35 --without-librtmp \
40 --without-nghttp2 \ 36 --without-nghttp2 \
41 --without-nss \ 37 --without-nss \
42 --without-cyassl \ 38 --without-cyassl \
43 --without-polarssl \ 39 --without-polarssl \
44 --without-ssl \ 40 --without-ssl \
45 --without-winssl \ 41 --without-winssl \
46 --without-darwinssl \ 42 --without-darwinssl \
47 --disable-sspi \ 43 --disable-sspi \
48 --disable-ntlm-wb \ 44 --disable-ntlm-wb \
49 --disable-ldap \ 45 --disable-ldap \
50 --disable-rtsp \ 46 --disable-rtsp \
51 --disable-dict \ 47 --disable-dict \
52 --disable-telnet \ 48 --disable-telnet \
53 --disable-tftp \ 49 --disable-tftp \
54 --disable-pop3 \ 50 --disable-pop3 \
55 --disable-imap \ 51 --disable-imap \
56 --disable-smtp \ 52 --disable-smtp \
57 --disable-gopher \ 53 --disable-gopher \
58 --disable-file \ 54 --disable-file \
59 --disable-ftp \ 55 --disable-ftp \
60 --disable-smb \ 56 --disable-smb \
61 --disable-ares 57 --disable-ares
62 make 58 make
63} 59}
64 60
65check() { 61check() {
66 cd "$builddir"
67 make -C tests nonflaky-test 62 make -C tests nonflaky-test
68} 63}
69 64
70package() { 65package() {
71 cd "$builddir" 66 make DESTDIR="$pkgdir" install
72 make DESTDIR="$pkgdir" install
73 #install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
74} 67}
75 68
76libgnurl() { 69libgnurl() {