aboutsummaryrefslogtreecommitdiff
path: root/contrib/guix/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/guix/gnu')
-rw-r--r--contrib/guix/gnu/packages/gnunet.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/contrib/guix/gnu/packages/gnunet.scm b/contrib/guix/gnu/packages/gnunet.scm
index 3a1943757..a91c69a11 100644
--- a/contrib/guix/gnu/packages/gnunet.scm
+++ b/contrib/guix/gnu/packages/gnunet.scm
@@ -245,8 +245,14 @@ supports HTTP, HTTPS and GnuTLS.")
245 "See COPYING in the distribution.")) 245 "See COPYING in the distribution."))
246 (home-page "https://gnunet.org/gnurl"))) 246 (home-page "https://gnunet.org/gnurl")))
247 247
248(define %source-dir (dirname (current-filename)))
249 248
249(define (repeat f n)
250 (if (= n 1)
251 f
252 (lambda (x) (f ((repeat f (- n 1)) x)))))
253
254(define %source-dir ((repeat dirname 5) (current-filename)))
255
250(define (git-output . args) 256(define (git-output . args)
251 "Execute 'git ARGS ...' command and return its output without trailing 257 "Execute 'git ARGS ...' command and return its output without trailing
252newspace." 258newspace."
@@ -260,7 +266,7 @@ newspace."
260 (git-output "describe" "--tags")) 266 (git-output "describe" "--tags"))
261 267
262(define (git-sources) 268(define (git-sources)
263 (local-file (dirname (dirname (dirname (dirname %source-dir)))) 269 (local-file %source-dir
264 #:recursive? #t 270 #:recursive? #t
265 #:select? (git-predicate %source-dir))) 271 #:select? (git-predicate %source-dir)))
266 272