aboutsummaryrefslogtreecommitdiff
path: root/contrib/scripts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/scripts/Makefile.am')
-rw-r--r--contrib/scripts/Makefile.am24
1 files changed, 19 insertions, 5 deletions
diff --git a/contrib/scripts/Makefile.am b/contrib/scripts/Makefile.am
index 367e5c4c9..f8b7ec3d1 100644
--- a/contrib/scripts/Makefile.am
+++ b/contrib/scripts/Makefile.am
@@ -9,7 +9,16 @@ noinst_SCRIPTS = \
9 removetrailingwhitespace.py \ 9 removetrailingwhitespace.py \
10 gnunet_pyexpect.py \ 10 gnunet_pyexpect.py \
11 gnunet_janitor.py \ 11 gnunet_janitor.py \
12 gnunet-chk.py 12 gnunet-chk.py \
13 $(awkSCRIPTS)
14
15# FIXME: read into AWK_SCRIPTS autotools builtin.
16if HAVE_AWK
17awkSCRIPTS = \
18 check-texinfo.awk
19else
20awkSCRIPTS =
21endif
13 22
14bin_SCRIPTS = \ 23bin_SCRIPTS = \
15 gnunet-bugreport \ 24 gnunet-bugreport \
@@ -24,13 +33,12 @@ EXTRA_DIST = \
24 $(SCRIPTS) \ 33 $(SCRIPTS) \
25 removetrailingwhitespace.py.in \ 34 removetrailingwhitespace.py.in \
26 pydiffer.py.in \ 35 pydiffer.py.in \
27 gnunet-suidfix 36 gnunet-suidfix \
37 check-texinfo.awk.in
28 38
29CLEANFILES = \ 39CLEANFILES = \
30 $(noinst_SCRIPTS) 40 $(noinst_SCRIPTS)
31 41
32do_subst = $(AWK) -v py="$(PYTHON)" '{gsub("@PYTHONEXE@",py); print $$0}'
33
34# Use SUFFIX Extension rules, they are more portable for every 42# Use SUFFIX Extension rules, they are more portable for every
35# implementation of 'make'. 43# implementation of 'make'.
36# You'll also run into the "'%' is a GNU make extension warning" 44# You'll also run into the "'%' is a GNU make extension warning"
@@ -44,5 +52,11 @@ do_subst = $(AWK) -v py="$(PYTHON)" '{gsub("@PYTHONEXE@",py); print $$0}'
44SUFFIXES = .py.in .py 52SUFFIXES = .py.in .py
45 53
46.py.in.py: 54.py.in.py:
47 $(do_subst) < $< > $@ 55 $(AWK) -v bdir="$(bindir)" -v py="$(PYTHON)" -v awkay="$(AWK_BINARY)" -v pfx="$(prefix)" -v prl="$(PERL)" -v sysconfdirectory="$(sysconfdir)" -v pkgdatadirectory="$(pkgdatadir)" -f $(top_srcdir)/bin/dosubst.awk < $< > $@
48 chmod +x $@ 56 chmod +x $@
57
58if HAVE_AWK
59check-texinfo.awk: check-texinfo.awk.in Makefile
60 $(AWK) -v bdir="$(bindir)" -v py="$(PYTHON)" -v awkay="$(AWK_BINARY)" -v pfx="$(prefix)" -v prl="$(PERL)" -v sysconfdirectory="$(sysconfdir)" -v pkgdatadirectory="$(pkgdatadir)" -f $(top_srcdir)/bin/dosubst.awk < $(srcdir)/check-texinfo.awk.in > check-texinfo.awk
61 chmod +x check-texinfo.awk
62endif