aboutsummaryrefslogtreecommitdiff
path: root/contrib/scripts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/scripts/Makefile.am')
-rw-r--r--contrib/scripts/Makefile.am13
1 files changed, 7 insertions, 6 deletions
diff --git a/contrib/scripts/Makefile.am b/contrib/scripts/Makefile.am
index 756119ada..204167e82 100644
--- a/contrib/scripts/Makefile.am
+++ b/contrib/scripts/Makefile.am
@@ -1,5 +1,6 @@
1# This Makefile.am is in the public domain 1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include -I$(top_builddir)/src/include 2AM_CPPFLAGS = -I$(top_srcdir)/src/include -I$(top_builddir)/src/include
3libexecdir= $(pkglibdir)/libexec/
3 4
4SUBDIRS = gnunet-logread 5SUBDIRS = gnunet-logread
5 6
@@ -21,7 +22,10 @@ noinst_SCRIPTS = \
21 $(awkSCRIPTS) 22 $(awkSCRIPTS)
22 23
23bin_SCRIPTS = \ 24bin_SCRIPTS = \
24 gnunet-bugreport \ 25 gnunet-bugreport
26
27# This script is not documented and its usage is quite uncommon.
28libexec_SCRIPTS = \
25 gnunet-suidfix 29 gnunet-suidfix
26 30
27EXTRA_DIST = \ 31EXTRA_DIST = \
@@ -39,14 +43,11 @@ EXTRA_DIST = \
39 find_typedefs.py \ 43 find_typedefs.py \
40 pydmesg \ 44 pydmesg \
41 visualize_stats.sh \ 45 visualize_stats.sh \
42 changelog_delta.sh \
43 debug \ 46 debug \
44 build_cscope.sh \ 47 build_cscope.sh \
45 lint/lint-man.sh \ 48 lint/lint-man.sh \
46 lint/lint-python.sh \ 49 lint/lint-python.sh \
47 revisionary.sh \ 50 revisionary.sh \
48 netjail/netjail_core.sh \
49 netjail/netjail_setup_internet.sh \
50 regression.sh \ 51 regression.sh \
51 doc/texinfo-hacks.el \ 52 doc/texinfo-hacks.el \
52 afferify \ 53 afferify \
@@ -71,11 +72,11 @@ CLEANFILES = \
71SUFFIXES = .py.in .py 72SUFFIXES = .py.in .py
72 73
73.py.in.py: 74.py.in.py:
74 $(AWK) -v py="$(PYTHON)" -f $(top_srcdir)/bin/dosubst.awk < $< > $@ 75 $(AWK) -v py="$(PYTHON)" -f $(top_srcdir)/scripts/dosubst.awk < $< > $@
75 chmod +x $@ 76 chmod +x $@
76 77
77if HAVE_AWK 78if HAVE_AWK
78check-texinfo.awk: check-texinfo.awk.in Makefile 79check-texinfo.awk: check-texinfo.awk.in Makefile
79 $(AWK) -v awkay="$(AWK_BINARY)" -f $(top_srcdir)/bin/dosubst.awk < $(srcdir)/check-texinfo.awk.in > check-texinfo.awk 80 $(AWK) -v awkay="$(AWK_BINARY)" -f $(top_srcdir)/scripts/dosubst.awk < $(srcdir)/check-texinfo.awk.in > check-texinfo.awk
80 chmod +x check-texinfo.awk 81 chmod +x check-texinfo.awk
81endif 82endif