aboutsummaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am33
1 files changed, 26 insertions, 7 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index a9ad69954..b45362d38 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,18 +1,37 @@
1# This Makefile.am is in the public domain 1# This Makefile.am is in the public domain
2 2
3SUBDIRS = .
3 4
4if DOCUMENTATION 5if HAVE_DOXY_BINARY
5 SUBDIRS = doxygen handbook tutorial 6 SUBDIRS += doxygen
6endif 7endif
7 8
8if !DOCUMENTATION 9# OpenBSD is a bit iffy wrt sphinx make info
9 SUBDIRS = doxygen 10if OPENBSD
11all-local:
12 cd handbook/texinfo && make || touch gnunet.info
13GNUNET_TEXI =
14else
15GNUNET_TEXI = handbook/texinfo/gnunet.texi
10endif 16endif
11 17
18install-data-hook:
19 mkdir -p $(DESTDIR)$(docdir)
20 cp -pr handbook/html $(DESTDIR)$(docdir)
21 mkdir -p $(DESTDIR)$(infodir)
22 cp -pr handbook/texinfo/gnunet.info $(DESTDIR)$(infodir)
23
12if INCLUDE_MANPAGES 24if INCLUDE_MANPAGES
13 SUBDIRS += man 25SUBDIRS += man
14endif 26endif
15 27
16EXTRA_DIST = \ 28AM_MAKEINFOFLAGS = --no-headers --no-split
29
30info_TEXINFOS = \
31 $(GNUNET_TEXI)
32
33EXTRA_DIST = \
34 handbook/texinfo \
17 system_specific/outdated-and-old-installation-instructions.txt \ 35 system_specific/outdated-and-old-installation-instructions.txt \
18 system_specific/FROM_SOURCE 36 system_specific/FROM_SOURCE \
37 handbook/html