aboutsummaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am28
1 files changed, 7 insertions, 21 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 63af26bbd..20eebaf30 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,37 +1,23 @@
1# This Makefile.am is in the public domain 1# This Makefile.am is in the public domain
2 2
3SUBDIRS = . 3# A note on sphinx:
4# gnunet-handbook does not have a Makefile.am.
5# It only supports building the documentation (and cleanup).
6# So, the only targets used are "make (all)" and "make clean".
7# Actuall installation of manpages/docs is done below
8
9SUBDIRS = sphinx .
4 10
5if HAVE_DOXY_BINARY 11if HAVE_DOXY_BINARY
6 SUBDIRS += doxygen 12 SUBDIRS += doxygen
7endif 13endif
8 14
9sphinx/_build/texinfo/gnunet.info:
10 cd sphinx && make info
11
12sphinx/_build/html:
13 cd sphinx && make html
14
15sphinx: sphinx/_build/texinfo/gnunet.info sphinx/_build/html
16 cd sphinx && make html info
17
18install-data-hook: sphinx 15install-data-hook: sphinx
19 mkdir -p $(DESTDIR)$(docdir) 16 mkdir -p $(DESTDIR)$(docdir)
20 cp -pr sphinx/_build/html $(DESTDIR)$(docdir) 17 cp -pr sphinx/_build/html $(DESTDIR)$(docdir)
21 mkdir -p $(DESTDIR)$(infodir) 18 mkdir -p $(DESTDIR)$(infodir)
22 cp -pr sphinx/_build/texinfo/gnunet.info $(DESTDIR)$(infodir) 19 cp -pr sphinx/_build/texinfo/gnunet.info $(DESTDIR)$(infodir)
23 20
24clean-local:
25 cd sphinx && make clean
26
27sphinx/_build/man/gnunet.1:
28 cd sphinx && make man
29
30sphinx-man:
31 cd sphinx && make man
32
33.DEFAULT: sphinx-man
34
35if INCLUDE_MANPAGES 21if INCLUDE_MANPAGES
36man_MANS = \ 22man_MANS = \
37 sphinx/_build/man/gnunet.1 \ 23 sphinx/_build/man/gnunet.1 \