aboutsummaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 508326781..ebf336dff 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -50,13 +50,19 @@ EXTRA_DIST = \
50 $(gnunet_TEXINFOS) \ 50 $(gnunet_TEXINFOS) \
51 $(gnunet_doc_images) 51 $(gnunet_doc_images)
52 52
53doc-pdf: 53version.texi:
54 echo "@set UPDATED $(date +'%d %B %Y')" > $@
55 echo "@set UPDATED-MONTH $(date +'%B %Y')" >> $@
56 echo "@set EDITION $(PACKAGE_VERSION)" >> $@
57 echo "@set VERSION $(PACKAGE_VERSION)" >> $@
58
59doc-pdf: doc/version.texi
54 @makeinfo --pdf --quiet gnunet.texi 60 @makeinfo --pdf --quiet gnunet.texi
55 61
56doc-html: 62doc-html: doc/version.texi
57 @makeinfo --html gnunet.texi 63 @makeinfo --html gnunet.texi
58 64
59doc-info: 65doc-info: doc/version.texi
60 @makeinfo --no-split gnunet.texi 66 @makeinfo --no-split gnunet.texi
61 67
62# FIXME: rm *.html and *.pdf 68# FIXME: rm *.html and *.pdf
@@ -64,3 +70,5 @@ doc-clean:
64 @rm *.aux *.log *.toc *.cp *.cps 70 @rm *.aux *.log *.toc *.cp *.cps
65 71
66doc-all: doc-pdf doc-html doc-info 72doc-all: doc-pdf doc-html doc-info
73
74.PHONY: version.texi