aboutsummaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am81
1 files changed, 29 insertions, 52 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 74b1300b4..bb0c5e0bf 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -11,6 +11,8 @@ infoimagedir = $(infodir)/images
11# $(DOT_FILES:%.dot=%.eps) \ 11# $(DOT_FILES:%.dot=%.eps) \
12# $(DOT_FILES:%.dot=%.pdf) 12# $(DOT_FILES:%.dot=%.pdf)
13 13
14AM_MAKEINFOHTMLFLAGS = --no-split --css-ref=docstyle.css
15
14dist_infoimage_DATA = \ 16dist_infoimage_DATA = \
15 images/gnunet-gtk-0-10-gns-a-done.png \ 17 images/gnunet-gtk-0-10-gns-a-done.png \
16 images/gnunet-gtk-0-10-gns-a.png \ 18 images/gnunet-gtk-0-10-gns-a.png \
@@ -106,7 +108,7 @@ gnunet_tutorial_examples = \
106 026.c 108 026.c
107 109
108info_TEXINFOS = \ 110info_TEXINFOS = \
109 gnunet.texi \ 111 gnunet.texi \
110 gnunet-c-tutorial.texi 112 gnunet-c-tutorial.texi
111 113
112gnunet_TEXINFOS = \ 114gnunet_TEXINFOS = \
@@ -114,6 +116,7 @@ gnunet_TEXINFOS = \
114 chapters/installation.texi \ 116 chapters/installation.texi \
115 chapters/philosophy.texi \ 117 chapters/philosophy.texi \
116 chapters/user.texi \ 118 chapters/user.texi \
119 chapters/vocabulary.texi \
117 fdl-1.3.texi \ 120 fdl-1.3.texi \
118 gpl-3.0.texi 121 gpl-3.0.texi
119 122
@@ -122,7 +125,8 @@ EXTRA_DIST = \
122 outdated-and-old-installation-instructions.txt \ 125 outdated-and-old-installation-instructions.txt \
123 gnunet-c-tutorial-v1.pdf \ 126 gnunet-c-tutorial-v1.pdf \
124 $(gnunet_tutorial_examples) \ 127 $(gnunet_tutorial_examples) \
125 README.txt 128 README.txt \
129 docstyle.css
126 130
127 131
128# $(DOT_FILES) \ 132# $(DOT_FILES) \
@@ -152,11 +156,11 @@ lego_stack.png: images/lego_stack.svg
152 pngcrush images/lego_stack.png images/lego_stack.png 156 pngcrush images/lego_stack.png images/lego_stack.png
153 157
154# FIXME: The usage of 'date' strings causes a warning. 158# FIXME: The usage of 'date' strings causes a warning.
155version.texi: 159# version.texi:
156 echo "@set UPDATED $(date +'%d %B %Y')" > $@ 160# echo "@set UPDATED $(date +'%d %B %Y')" > $@
157 echo "@set UPDATED-MONTH $(date +'%B %Y')" >> $@ 161# echo "@set UPDATED-MONTH $(date +'%B %Y')" >> $@
158 echo "@set EDITION $(PACKAGE_VERSION)" >> $@ 162# echo "@set EDITION $(PACKAGE_VERSION)" >> $@
159 echo "@set VERSION $(PACKAGE_VERSION)" >> $@ 163# echo "@set VERSION $(PACKAGE_VERSION)" >> $@
160 164
161# Workaround for makeinfo error. Whcih in turn introduces more 165# Workaround for makeinfo error. Whcih in turn introduces more
162# date-related 'warnings'. Well. 166# date-related 'warnings'. Well.
@@ -166,45 +170,11 @@ version2.texi:
166 echo "@set EDITION $(PACKAGE_VERSION)" >> $@ 170 echo "@set EDITION $(PACKAGE_VERSION)" >> $@
167 echo "@set VERSION $(PACKAGE_VERSION)" >> $@ 171 echo "@set VERSION $(PACKAGE_VERSION)" >> $@
168 172
169doc-pdf: version.texi
170 @makeinfo --pdf --quiet gnunet.texi
171doc-pdf-tutorial: version.texi version2.texi
172 @makeinfo --pdf --quiet gnunet-c-tutorial.texi
173
174doc-html: version.texi
175 @makeinfo --html gnunet.texi
176doc-html-tutorial: version.texi version2.texi
177 @makeinfo --html gnunet-c-tutorial.texi
178
179doc-info: version.texi
180 @makeinfo --no-split gnunet.texi
181doc-info-tutorial: version.texi version2.texi
182 @makeinfo --no-split gnunet-c-tutorial.texi
183
184# FIXME: rm *.html and *.pdf 173# FIXME: rm *.html and *.pdf
185doc-clean: 174#doc-clean:
186 @rm *.aux *.log *.toc *.cp *.cps 175# @rm *.aux *.log *.toc *.cp *.cps
187
188doc-all: doc-pdf doc-html doc-info doc-pdf-tutorial doc-html-tutorial doc-info-tutorial
189
190doc-pdf-noise: version.texi
191 @makeinfo --pdf gnunet.texi
192doc-pdf-tutorial-noise: version.texi version2.texi
193 @makeinfo --pdf gnunet-c-tutorial.texi
194
195doc-html-noise: version.texi
196 @makeinfo --html gnunet.texi
197doc-html-tutorial-noise: version.texi version2.texi
198 @makeinfo --html gnunet-c-tutorial.texi
199
200doc-info-noise: version.texi
201 @makeinfo --no-split gnunet.texi
202doc-info-tutorial-noise: version.texi version2.texi
203 @makeinfo --no-split gnunet-c-tutorial.texi
204
205doc-all-give-me-the-noise: doc-pdf-noise doc-html-noise doc-info-noise doc-pdf-tutorial-noise doc-html-tutorial-noise doc-info-tutorial-noise
206 176
207doc-all-install: doc-all-give-me-the-noise 177doc-all-install:
208 @mkdir -p $(DESTDIR)/$(docdir) 178 @mkdir -p $(DESTDIR)/$(docdir)
209 @mkdir -p $(DESTDIR)/$(infoimagedir) 179 @mkdir -p $(DESTDIR)/$(infoimagedir)
210 @mkdir -p $(DESTDIR)/$(infodir) 180 @mkdir -p $(DESTDIR)/$(infodir)
@@ -212,17 +182,24 @@ doc-all-install: doc-all-give-me-the-noise
212 @install -m 0755 gnunet-c-tutorial.pdf $(DESTDIR)/$(docdir) 182 @install -m 0755 gnunet-c-tutorial.pdf $(DESTDIR)/$(docdir)
213 @install -m 0755 gnunet-c-tutorial.info $(DESTDIR)/$(infodir) 183 @install -m 0755 gnunet-c-tutorial.info $(DESTDIR)/$(infodir)
214 @install -m 0755 gnunet.info $(DESTDIR)/$(infodir) 184 @install -m 0755 gnunet.info $(DESTDIR)/$(infodir)
215 @cp -r gnunet $(DESTDIR)/$(docdir) 185 @install gnunet.html $(DESTDIR)/$(docdir)
216 @cp -r gnunet-c-tutorial $(DESTDIR)/$(docdir) 186 @install gnunet-c-tutorial.html $(DESTDIR)/$(docdir)
217 187
218# @cp -r images $(DESTDIR)/$(infoimagedir) 188# @cp -r images $(DESTDIR)/$(infoimagedir)
219 189
220# TODO: Add more to clean. 190# TODO: Add more to clean.
221# clean: 191clean:
222# @rm gnunet.pdf 192 @rm gnunet.pdf
223# @rm gnunet-c-tutorial.pdf 193 @rm gnunet.html
224# @rm gnunet.info 194 @rm gnunet.info
225# @rm gnunet-c-tutorial.info 195 @rm gnunet.info-1
196 @rm gnunet.info-2
197 @rm gnunet.info-3
198 @rm gnunet-c-tutorial.pdf
199 @rm gnunet-c-tutorial.info
200 @rm gnunet-c-tutorial.html
201 @rm -r gnunet.t2p
202 @rm -r gnunet-c-tutorial.t2p
226 203
227# CLEANFILES = \ 204# CLEANFILES = \
228# gnunet.log \ 205# gnunet.log \
@@ -232,7 +209,7 @@ doc-all-install: doc-all-give-me-the-noise
232# $(wildcard *.cp) \ 209# $(wildcard *.cp) \
233# $(wildcard *.cps) 210# $(wildcard *.cps)
234 211
235.PHONY: version.texi 212#.PHONY: version.texi
236# if HAVE_EXTENDED_DOCUMENTATION_BUILDING_PDF 213# if HAVE_EXTENDED_DOCUMENTATION_BUILDING_PDF
237 214
238# if HAVE_EXTENDED_DOCUMENTATION_BUILDING_HTML 215# if HAVE_EXTENDED_DOCUMENTATION_BUILDING_HTML