aboutsummaryrefslogtreecommitdiff
path: root/doc/documentation/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/documentation/Makefile.am')
-rw-r--r--doc/documentation/Makefile.am245
1 files changed, 0 insertions, 245 deletions
diff --git a/doc/documentation/Makefile.am b/doc/documentation/Makefile.am
deleted file mode 100644
index cd3fca854..000000000
--- a/doc/documentation/Makefile.am
+++ /dev/null
@@ -1,245 +0,0 @@
1# This Makefile.am is in the public domain
2docdir = $(datadir)/doc/gnunet/
3
4infoimagedir = $(infodir)/images
5
6#DOT_FILES = images/$(wildcard *.dot)
7
8#DOT_VECTOR_GRAPHICS = \
9# $(DOT_FILES:%.dot=%.eps) \
10# $(DOT_FILES:%.dot=%.pdf)
11
12AM_MAKEINFOHTMLFLAGS = --no-split --css-ref=docstyle.css
13
14dist_infoimage_DATA = \
15 images/gnunet-gtk-0-10-gns-a-done.png \
16 images/gnunet-gtk-0-10-gns-a.png \
17 images/daemon_lego_block.png \
18 images/gnunet-gtk-0-10-gns.png \
19 images/gnunet-0-10-peerinfo.png \
20 images/gnunet-gtk-0-10-identity.png \
21 images/gnunet-fs-gtk-0-10-star-tab.png \
22 images/gnunet-gtk-0-10-download-area.png \
23 images/gnunet-gtk-0-10-search-selected.png \
24 images/gnunet-gtk-0-10-fs-menu.png \
25 images/gnunet-gtk-0-10-traffic.png \
26 images/gnunet-gtk-0-10-fs.png \
27 images/gnunet-namestore-gtk-phone.png \
28 images/gnunet-gtk-0-10-fs-publish-editing.png \
29 images/gnunet-namestore-gtk-vpn.png \
30 images/gnunet-gtk-0-10-fs-published.png \
31 images/gnunet-setup-exit.png \
32 images/gnunet-gtk-0-10-fs-publish.png \
33 images/iceweasel-preferences.png \
34 images/gnunet-gtk-0-10-fs-publish-select.png \
35 images/iceweasel-proxy.png \
36 images/gnunet-gtk-0-10-fs-publish-with-file_0.png \
37 images/service_lego_block.png \
38 images/gnunet-gtk-0-10-fs-publish-with-file.png \
39 images/service_stack.png \
40 images/gnunet-gtk-0-10-fs-search.png \
41 images/gnunet-tutorial-service.png \
42 images/gnunet-tutorial-system.png \
43 images/daemon_lego_block.svg \
44 images/lego_stack.svg \
45 images/service_lego_block.svg \
46 images/structure.dot \
47 images/gns.dot
48
49# images/$(wildcard *.png) \
50# images/$(wildcard *.svg)
51# $(DOT_FILES:%.dot=%.png)
52
53#DOT_OPTIONS = \
54# -Gratio=.9 -Gnodesep=.005 -Granksep=.00005 \
55# -Nfontsite=9 -Nheight=.1 -Nwidth=.1
56
57# .dot.png:
58# $(AM_V_DOT)$(DOT) -Tpng $(DOT_OPTIONS) < "$<" > "$(srcdir)/$@.tmp"; \
59# mv "$(srcdir)/$@.tmp" "$(srcdir)/$@"
60
61# .dot.pdf:
62# $(AM_V_DOT)$(DOT) -Tpdf $(DOT_OPTIONS) < "$<" > "$(srcdir)/$@.tmp"; \
63# mv "$(srcdir)/$@.tmp" "$(srcdir)/$@"
64
65# .dot.eps:
66# $(AM_V_DOT)$(DOT) -Teps $(DOT_OPTIONS) < "$<" > "$(srcdir)/$@.tmp"; \
67# mv "$(srcdir)/$@.tmp" "$(srcdir)/$@"
68
69# .png.eps:
70# $(AM_V_GEN)convert "$<" "$@-tmp.eps"; \
71# mv "$@-tmp.eps" "$@"
72
73# pdf-local: $(DOT_FILES=%.dot=$(top_srcdir)/%.pdf)
74# info-local: $(DOT_FILES=%.dot=$(top_srcdir)/%.png)
75# ps-local: $(DOT_FILES=%.dot=$(top_srcdir)/%.eps) \
76# $(top_srcdir)/%D%/images/coreutils-size-map.eps
77# dvi-local: ps-local
78
79
80gnunet_tutorial_examples = \
81 tutorial-examples/001.c \
82 tutorial-examples/002.c \
83 tutorial-examples/003.c \
84 tutorial-examples/004.c \
85 tutorial-examples/005.c \
86 tutorial-examples/006.c \
87 tutorial-examples/007.c \
88 tutorial-examples/008.c \
89 tutorial-examples/009.c \
90 tutorial-examples/010.c \
91 tutorial-examples/011.c \
92 tutorial-examples/012.c \
93 tutorial-examples/013.c \
94 tutorial-examples/013.1.c \
95 tutorial-examples/014.c \
96 tutorial-examples/015.c \
97 tutorial-examples/016.c \
98 tutorial-examples/017.c \
99 tutorial-examples/018.c \
100 tutorial-examples/019.c \
101 tutorial-examples/020.c \
102 tutorial-examples/021.c \
103 tutorial-examples/022.c \
104 tutorial-examples/023.c \
105 tutorial-examples/024.c \
106 tutorial-examples/025.Makefile.am \
107 tutorial-examples/026.c
108
109info_TEXINFOS = \
110 gnunet.texi \
111 gnunet-c-tutorial.texi
112
113gnunet_TEXINFOS = \
114 chapters/developer.texi \
115 chapters/preface.texi \
116 chapters/philosophy.texi \
117 chapters/installation.texi \
118 chapters/user.texi \
119 chapters/vocabulary.texi \
120 chapters/configuration.texi \
121 chapters/contributing.texi \
122 fdl-1.3.texi \
123 gpl-3.0.texi
124
125EXTRA_DIST = \
126 $(gnunet_TEXINFOS) \
127 $(gnunet_tutorial_examples) \
128 htmlxref.cnf \
129 gversion.texi
130 run-gendocs.sh \
131 docstyle.css
132
133
134# $(DOT_FILES) \
135# $(DOT_VECTOR_GRAPHICS)
136
137DISTCLEANFILES = \
138 gnunet.cps \
139 gnunet-c-tutorial.cps \
140 chapters/developer.cps \
141 chapters/installation.cps \
142 chapter/philosophy.cps \
143 chapters/user.cps \
144 chapters/configuration.cps \
145 chapters/terminology.cps \
146 chapters/vocabulary.cps \
147 fdl-1.3.cps \
148 agpl-3.0.cps \
149 gpl-3.0.cps
150
151# if HAVE_EXTENDED_DOCUMENTATION_BUILDING
152daemon_lego_block.png: images/daemon_lego_block.svg
153 convert images/daemon_lego_block.svg images/daemon_lego_block.png &&
154 pngcrush images/daemon_lego_block.png images/daemon_lego_block.png
155
156service_lego_block.png: images/service_lego_block.svg
157 convert images/service_lego_block.svg images/service_lego_block.png &&
158 pngcrush images/service_lego_block.png images/serivce_lego_block.png
159
160lego_stack.png: images/lego_stack.svg
161 convert images/lego_stack.svg images/lego_stack.png &&
162 pngcrush images/lego_stack.png images/lego_stack.png
163
164# XXX: is this sed invocation portable enough? otherwise try tr(1).
165version.texi/replacement: version.texi/replacement/revert
166 @sed -i "s/GPACKAGE_VERSION/$(PACKAGE_VERSION)/g" gversion.texi
167
168version.texi/replacement/revert:
169 @echo "@set VERSION GPACKAGE_VERSION" > gversion.texi
170 @echo "@set EDITION GPACKAGE_VERSION" >> gversion.texi
171
172if SECTION7
173gnunet-c-tutorial.7: version.texi/replacement
174 @echo Attempting to output an mdoc formatted section 7 document
175 @texi2mdoc -I$(pwd):$(pwd)/chapters gnunet-c-tutorial.texi > ../man/gnunet-c-tutorial.7
176
177gnunet-documentation.7: version.texi/replacement
178 @echo Attempting to output an mdoc formatted section 7 document
179 @texi2mdoc -I$(pwd):$(pwd)/chapters gnunet.texi > ../man/gnunet-documentation.7
180
181# TODO: (Maybe) other outputs resulting from this.
182endif
183
184# FIXME: rm *.html and *.pdf
185#doc-clean:
186# @rm *.aux *.log *.toc *.cp *.cps
187
188all: version.texi/replacement
189
190doc-all-install:
191 @mkdir -p $(DESTDIR)/$(docdir)
192 @mkdir -p $(DESTDIR)/$(infoimagedir)
193 @mkdir -p $(DESTDIR)/$(infodir)
194 @install -m 0755 gnunet.pdf $(DESTDIR)/$(docdir)
195 @install -m 0755 gnunet-c-tutorial.pdf $(DESTDIR)/$(docdir)
196 @install -m 0755 gnunet-c-tutorial.info $(DESTDIR)/$(infodir)
197 @install -m 0755 gnunet.info $(DESTDIR)/$(infodir)
198 @install gnunet.html $(DESTDIR)/$(docdir)
199 @install gnunet-c-tutorial.html $(DESTDIR)/$(docdir)
200
201doc-gendoc-install:
202 @mkdir -p $(DESTDIR)/$(docdir)
203 @cp -r manual $(DESTDIR)/$(docdir)
204
205# @cp -r images $(DESTDIR)/$(infoimagedir)
206
207dev-build: version.texi/replacement
208 @makeinfo --pdf gnunet.texi
209 @makeinfo --pdf gnunet-c-tutorial.texi
210 @makeinfo --html gnunet.texi
211 @makeinfo --html gnunet-c-tutorial.texi
212 @makeinfo --no-split gnunet.texi
213 @makeinfo --no-split gnunet-c-tutorial.texi
214
215# TODO: Add more to clean.
216clean: version.texi/replacement/revert
217 @rm -f gnunet.pdf
218 @rm -f gnunet.html
219 @rm -f gnunet.info
220 @rm -f gnunet.info-1
221 @rm -f gnunet.info-2
222 @rm -f gnunet.info-3
223 @rm -f gnunet-c-tutorial.pdf
224 @rm -f gnunet-c-tutorial.info
225 @rm -f gnunet-c-tutorial.html
226 @rm -fr gnunet.t2p
227 @rm -fr gnunet-c-tutorial.t2p
228 @rm -fr manual
229
230# CLEANFILES = \
231# gnunet.log \
232# gnunet-c-tutorial.log \
233# $(wildcard *.aux) \
234# $(wildcard *.toc) \
235# $(wildcard *.cp) \
236# $(wildcard *.cps)
237
238#.PHONY: version.texi
239# if HAVE_EXTENDED_DOCUMENTATION_BUILDING_PDF
240
241# if HAVE_EXTENDED_DOCUMENTATION_BUILDING_HTML
242
243# endif
244# endif
245# endif