aboutsummaryrefslogtreecommitdiff
path: root/doc/documentation/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/documentation/Makefile.am')
-rw-r--r--doc/documentation/Makefile.am214
1 files changed, 214 insertions, 0 deletions
diff --git a/doc/documentation/Makefile.am b/doc/documentation/Makefile.am
new file mode 100644
index 000000000..21852a9c3
--- /dev/null
+++ b/doc/documentation/Makefile.am
@@ -0,0 +1,214 @@
1# This Makefile.am is in the public domain
2docdir = $(datadir)/doc/gnunet/
3
4infoimagedir = $(infodir)/images
5
6#DOT_FILES = images/$(wildcard *.dot)
7
8#DOT_VECTOR_GRAPHICS = \
9# $(DOT_FILES:%.dot=%.eps) \
10# $(DOT_FILES:%.dot=%.pdf)
11
12AM_MAKEINFOHTMLFLAGS = --no-split --css-ref=docstyle.css
13
14dist_infoimage_DATA = \
15 images/gnunet-gtk-0-10-gns-a-done.png \
16 images/gnunet-gtk-0-10-gns-a.png \
17 images/daemon_lego_block.png \
18 images/gnunet-gtk-0-10-gns.png \
19 images/gnunet-0-10-peerinfo.png \
20 images/gnunet-gtk-0-10-identity.png \
21 images/gnunet-fs-gtk-0-10-star-tab.png \
22 images/gnunet-gtk-0-10.png \
23 images/gnunet-gtk-0-10-download-area.png \
24 images/gnunet-gtk-0-10-search-selected.png \
25 images/gnunet-gtk-0-10-fs-menu.png \
26 images/gnunet-gtk-0-10-traffic.png \
27 images/gnunet-gtk-0-10-fs.png \
28 images/gnunet-namestore-gtk-phone.png \
29 images/gnunet-gtk-0-10-fs-publish-editing.png \
30 images/gnunet-namestore-gtk-vpn.png \
31 images/gnunet-gtk-0-10-fs-published.png \
32 images/gnunet-setup-exit.png \
33 images/gnunet-gtk-0-10-fs-publish.png \
34 images/iceweasel-preferences.png \
35 images/gnunet-gtk-0-10-fs-publish-select.png \
36 images/iceweasel-proxy.png \
37 images/gnunet-gtk-0-10-fs-publish-with-file_0.png \
38 images/service_lego_block.png \
39 images/gnunet-gtk-0-10-fs-publish-with-file.png \
40 images/service_stack.png \
41 images/gnunet-gtk-0-10-fs-search.png \
42 images/gnunet-tutorial-service.png \
43 images/gnunet-tutorial-system.png \
44 images/daemon_lego_block.svg \
45 images/lego_stack.svg \
46 images/service_lego_block.svg \
47 images/structure.dot
48
49# images/$(wildcard *.png) \
50# images/$(wildcard *.svg)
51# $(DOT_FILES:%.dot=%.png)
52
53#DOT_OPTIONS = \
54# -Gratio=.9 -Gnodesep=.005 -Granksep=.00005 \
55# -Nfontsite=9 -Nheight=.1 -Nwidth=.1
56
57# .dot.png:
58# $(AM_V_DOT)$(DOT) -Tpng $(DOT_OPTIONS) < "$<" > "$(srcdir)/$@.tmp"; \
59# mv "$(srcdir)/$@.tmp" "$(srcdir)/$@"
60
61# .dot.pdf:
62# $(AM_V_DOT)$(DOT) -Tpdf $(DOT_OPTIONS) < "$<" > "$(srcdir)/$@.tmp"; \
63# mv "$(srcdir)/$@.tmp" "$(srcdir)/$@"
64
65# .dot.eps:
66# $(AM_V_DOT)$(DOT) -Teps $(DOT_OPTIONS) < "$<" > "$(srcdir)/$@.tmp"; \
67# mv "$(srcdir)/$@.tmp" "$(srcdir)/$@"
68
69# .png.eps:
70# $(AM_V_GEN)convert "$<" "$@-tmp.eps"; \
71# mv "$@-tmp.eps" "$@"
72
73# pdf-local: $(DOT_FILES=%.dot=$(top_srcdir)/%.pdf)
74# info-local: $(DOT_FILES=%.dot=$(top_srcdir)/%.png)
75# ps-local: $(DOT_FILES=%.dot=$(top_srcdir)/%.eps) \
76# $(top_srcdir)/%D%/images/coreutils-size-map.eps
77# dvi-local: ps-local
78
79gnunet_tutorial_examples = \
80 001.c \
81 002.c \
82 003.c \
83 004.c \
84 005.c \
85 006.c \
86 007.c \
87 008.c \
88 009.c \
89 010.c \
90 011.c \
91 012.c \
92 013.c \
93 013.1.c \
94 014.c \
95 015.c \
96 016.c \
97 017.c \
98 018.c \
99 019.c \
100 020.c \
101 021.c \
102 022.c \
103 023.c \
104 024.c \
105 025.c \
106 026.c
107
108info_TEXINFOS = \
109 gnunet.texi \
110 gnunet-c-tutorial.texi
111
112gnunet_TEXINFOS = \
113 chapters/developer.texi \
114 chapters/installation.texi \
115 chapters/philosophy.texi \
116 chapters/user.texi \
117 chapters/vocabulary.texi \
118 fdl-1.3.texi \
119 gpl-3.0.texi
120
121EXTRA_DIST = \
122 $(gnunet_TEXINFOS) \
123 $(gnunet_tutorial_examples) \
124 docstyle.css
125
126
127# $(DOT_FILES) \
128# $(DOT_VECTOR_GRAPHICS)
129
130DISTCLEANFILES = \
131 gnunet.cps \
132 gnunet-c-tutorial.cps \
133 chapters/developer.cps \
134 chapters/installation.cps \
135 chapter/philosophy.cps \
136 chapters/user.cps \
137 fdl-1.3.cps \
138 gpl-3.0.cps
139
140# if HAVE_EXTENDED_DOCUMENTATION_BUILDING
141daemon_lego_block.png: images/daemon_lego_block.svg
142 convert images/daemon_lego_block.svg images/daemon_lego_block.png &&
143 pngcrush images/daemon_lego_block.png images/daemon_lego_block.png
144
145service_lego_block.png: images/service_lego_block.svg
146 convert images/service_lego_block.svg images/service_lego_block.png &&
147 pngcrush images/service_lego_block.png images/serivce_lego_block.png
148
149lego_stack.png: images/lego_stack.svg
150 convert images/lego_stack.svg images/lego_stack.png &&
151 pngcrush images/lego_stack.png images/lego_stack.png
152
153# FIXME: The usage of 'date' strings causes a warning.
154# version.texi:
155# echo "@set UPDATED $(date +'%d %B %Y')" > $@
156# echo "@set UPDATED-MONTH $(date +'%B %Y')" >> $@
157# echo "@set EDITION $(PACKAGE_VERSION)" >> $@
158# echo "@set VERSION $(PACKAGE_VERSION)" >> $@
159
160# Workaround for makeinfo error. Whcih in turn introduces more
161# date-related 'warnings'. Well.
162version2.texi:
163 echo "@set UPDATED $(date +'%d %B %Y')" > $@
164 echo "@set UPDATED-MONTH $(date +'%B %Y')" >> $@
165 echo "@set EDITION $(PACKAGE_VERSION)" >> $@
166 echo "@set VERSION $(PACKAGE_VERSION)" >> $@
167
168# FIXME: rm *.html and *.pdf
169#doc-clean:
170# @rm *.aux *.log *.toc *.cp *.cps
171
172doc-all-install:
173 @mkdir -p $(DESTDIR)/$(docdir)
174 @mkdir -p $(DESTDIR)/$(infoimagedir)
175 @mkdir -p $(DESTDIR)/$(infodir)
176 @install -m 0755 gnunet.pdf $(DESTDIR)/$(docdir)
177 @install -m 0755 gnunet-c-tutorial.pdf $(DESTDIR)/$(docdir)
178 @install -m 0755 gnunet-c-tutorial.info $(DESTDIR)/$(infodir)
179 @install -m 0755 gnunet.info $(DESTDIR)/$(infodir)
180 @install gnunet.html $(DESTDIR)/$(docdir)
181 @install gnunet-c-tutorial.html $(DESTDIR)/$(docdir)
182
183# @cp -r images $(DESTDIR)/$(infoimagedir)
184
185# TODO: Add more to clean.
186clean:
187 @rm gnunet.pdf
188 @rm gnunet.html
189 @rm gnunet.info
190 @rm gnunet.info-1
191 @rm gnunet.info-2
192 @rm gnunet.info-3
193 @rm gnunet-c-tutorial.pdf
194 @rm gnunet-c-tutorial.info
195 @rm gnunet-c-tutorial.html
196 @rm -r gnunet.t2p
197 @rm -r gnunet-c-tutorial.t2p
198
199# CLEANFILES = \
200# gnunet.log \
201# gnunet-c-tutorial.log \
202# $(wildcard *.aux) \
203# $(wildcard *.toc) \
204# $(wildcard *.cp) \
205# $(wildcard *.cps)
206
207#.PHONY: version.texi
208# if HAVE_EXTENDED_DOCUMENTATION_BUILDING_PDF
209
210# if HAVE_EXTENDED_DOCUMENTATION_BUILDING_HTML
211
212# endif
213# endif
214# endif