aboutsummaryrefslogtreecommitdiff
path: root/doc/documentation/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/documentation/Makefile.am')
-rw-r--r--doc/documentation/Makefile.am32
1 files changed, 14 insertions, 18 deletions
diff --git a/doc/documentation/Makefile.am b/doc/documentation/Makefile.am
index 7eed6efb6..cd3fca854 100644
--- a/doc/documentation/Makefile.am
+++ b/doc/documentation/Makefile.am
@@ -126,6 +126,7 @@ EXTRA_DIST = \
126 $(gnunet_TEXINFOS) \ 126 $(gnunet_TEXINFOS) \
127 $(gnunet_tutorial_examples) \ 127 $(gnunet_tutorial_examples) \
128 htmlxref.cnf \ 128 htmlxref.cnf \
129 gversion.texi
129 run-gendocs.sh \ 130 run-gendocs.sh \
130 docstyle.css 131 docstyle.css
131 132
@@ -160,27 +161,20 @@ lego_stack.png: images/lego_stack.svg
160 convert images/lego_stack.svg images/lego_stack.png && 161 convert images/lego_stack.svg images/lego_stack.png &&
161 pngcrush images/lego_stack.png images/lego_stack.png 162 pngcrush images/lego_stack.png images/lego_stack.png
162 163
163# FIXME: The usage of 'date' strings causes a warning. 164# XXX: is this sed invocation portable enough? otherwise try tr(1).
164# version.texi: 165version.texi/replacement: version.texi/replacement/revert
165# echo "@set UPDATED $(date +'%d %B %Y')" > $@ 166 @sed -i "s/GPACKAGE_VERSION/$(PACKAGE_VERSION)/g" gversion.texi
166# echo "@set UPDATED-MONTH $(date +'%B %Y')" >> $@ 167
167# echo "@set EDITION $(PACKAGE_VERSION)" >> $@ 168version.texi/replacement/revert:
168# echo "@set VERSION $(PACKAGE_VERSION)" >> $@ 169 @echo "@set VERSION GPACKAGE_VERSION" > gversion.texi
169 170 @echo "@set EDITION GPACKAGE_VERSION" >> gversion.texi
170# Workaround for makeinfo error. Which in turn introduces more
171# date-related 'warnings' for GNUism. Well.
172version2.texi:
173 echo "@set UPDATED $(date +'%d %B %Y')" > $@
174 echo "@set UPDATED-MONTH $(date +'%B %Y')" >> $@
175 echo "@set EDITION $(PACKAGE_VERSION)" >> $@
176 echo "@set VERSION $(PACKAGE_VERSION)" >> $@
177 171
178if SECTION7 172if SECTION7
179gnunet-c-tutorial.7: version2.texi 173gnunet-c-tutorial.7: version.texi/replacement
180 @echo Attempting to output an mdoc formatted section 7 document 174 @echo Attempting to output an mdoc formatted section 7 document
181 @texi2mdoc -I$(pwd):$(pwd)/chapters gnunet-c-tutorial.texi > ../man/gnunet-c-tutorial.7 175 @texi2mdoc -I$(pwd):$(pwd)/chapters gnunet-c-tutorial.texi > ../man/gnunet-c-tutorial.7
182 176
183gnunet-documentation.7: version2.texi 177gnunet-documentation.7: version.texi/replacement
184 @echo Attempting to output an mdoc formatted section 7 document 178 @echo Attempting to output an mdoc formatted section 7 document
185 @texi2mdoc -I$(pwd):$(pwd)/chapters gnunet.texi > ../man/gnunet-documentation.7 179 @texi2mdoc -I$(pwd):$(pwd)/chapters gnunet.texi > ../man/gnunet-documentation.7
186 180
@@ -191,6 +185,8 @@ endif
191#doc-clean: 185#doc-clean:
192# @rm *.aux *.log *.toc *.cp *.cps 186# @rm *.aux *.log *.toc *.cp *.cps
193 187
188all: version.texi/replacement
189
194doc-all-install: 190doc-all-install:
195 @mkdir -p $(DESTDIR)/$(docdir) 191 @mkdir -p $(DESTDIR)/$(docdir)
196 @mkdir -p $(DESTDIR)/$(infoimagedir) 192 @mkdir -p $(DESTDIR)/$(infoimagedir)
@@ -208,7 +204,7 @@ doc-gendoc-install:
208 204
209# @cp -r images $(DESTDIR)/$(infoimagedir) 205# @cp -r images $(DESTDIR)/$(infoimagedir)
210 206
211dev-build: version.texi version2.texi 207dev-build: version.texi/replacement
212 @makeinfo --pdf gnunet.texi 208 @makeinfo --pdf gnunet.texi
213 @makeinfo --pdf gnunet-c-tutorial.texi 209 @makeinfo --pdf gnunet-c-tutorial.texi
214 @makeinfo --html gnunet.texi 210 @makeinfo --html gnunet.texi
@@ -217,7 +213,7 @@ dev-build: version.texi version2.texi
217 @makeinfo --no-split gnunet-c-tutorial.texi 213 @makeinfo --no-split gnunet-c-tutorial.texi
218 214
219# TODO: Add more to clean. 215# TODO: Add more to clean.
220clean: 216clean: version.texi/replacement/revert
221 @rm -f gnunet.pdf 217 @rm -f gnunet.pdf
222 @rm -f gnunet.html 218 @rm -f gnunet.html
223 @rm -f gnunet.info 219 @rm -f gnunet.info