aboutsummaryrefslogtreecommitdiff
path: root/doc/man/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/man/Makefile.am')
-rw-r--r--doc/man/Makefile.am8
1 files changed, 2 insertions, 6 deletions
diff --git a/doc/man/Makefile.am b/doc/man/Makefile.am
index 601a85555..a0283cf44 100644
--- a/doc/man/Makefile.am
+++ b/doc/man/Makefile.am
@@ -1,11 +1,7 @@
1# This Makefile.am is in the public domain 1# This Makefile.am is in the public domain
2 2
3do_subst = $(SED) -e 's,[@]SYSCONFDIR[@],$(sysconfdir),g'
4
5gnunet.conf.5: gnunet.conf.5.in Makefile 3gnunet.conf.5: gnunet.conf.5.in Makefile
6 $(do_subst) < $(srcdir)/gnunet.conf.5.in > gnunet.conf.5 4 $(AWK) -v bdir="$(bindir)" -v py="$(PYTHON)" -v awkay="$(AWK_BINARY)" -v pfx="$(prefix)" -v prl="$(PERL)" -v sysconfdirectory="$(sysconfdir)" -v pkgdatadirectory="$(pkgdatadir)" -f $(top_srcdir)/bin/dosubst.awk < $(srcdir)/gnunet.conf.5.in > $(srcdir)/gnunet.conf.5
7
8do_subst_pkgdatadir = $(SED) -e 's,[@]pkgdatadir[@],$(pkgdatadir),g'
9 5
10CLEANFILES = gnunet.conf.5 6CLEANFILES = gnunet.conf.5
11 7
@@ -28,7 +24,7 @@ if HAVE_MANDOC
28# I want and that the alternatives are depressing and 24# I want and that the alternatives are depressing and
29# nonfunctional. 25# nonfunctional.
30produce_html.sh: produce_html.sh.in Makefile 26produce_html.sh: produce_html.sh.in Makefile
31 $(do_subst_pkgdatadir) < $(srcdir)/produce_html.sh.in > produce_html.sh 27 $(AWK) -v bdir="$(bindir)" -v py="$(PYTHON)" -v awkay="$(AWK_BINARY)" -v pfx="$(prefix)" -v prl="$(PERL)" -v sysconfdirectory="$(sysconfdir)" -v pkgdatadirectory="$(pkgdatadir)" -f $(top_srcdir)/bin/dosubst.awk < $(srcdir)/produce_html.sh.in > produce_html.sh
32 @chmod +x produce_html.sh 28 @chmod +x produce_html.sh
33 29
34CLEANFILES += produce_html.sh 30CLEANFILES += produce_html.sh