aboutsummaryrefslogtreecommitdiff
path: root/doc/man/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/man/Makefile.am')
-rw-r--r--doc/man/Makefile.am31
1 files changed, 11 insertions, 20 deletions
diff --git a/doc/man/Makefile.am b/doc/man/Makefile.am
index e7045e8bf..6ab720826 100644
--- a/doc/man/Makefile.am
+++ b/doc/man/Makefile.am
@@ -1,20 +1,10 @@
1# This Makefile.am is in the public domain 1# This Makefile.am is in the public domain
2 2
3gnunet.conf.5: gnunet.conf.5.in Makefile 3gnunet.conf.5: gnunet.conf.5.in Makefile
4 $(AWK) -v bdir="$(bindir)" -v py="$(PYTHON)" -v awkay="$(AWK_BINARY)" -v pfx="$(prefix)" -v prl="$(PERL)" -v sysconfdirectory="$(sysconfdir)" -v pkgdatadirectory="$(pkgdatadir)" -f $(top_srcdir)/bin/dosubst.awk < $(srcdir)/gnunet.conf.5.in > $(srcdir)/gnunet.conf.5 4 $(AWK) -v bdir="$(bindir)" -v py="$(PYTHON)" -v awkay="$(AWK_BINARY)" -v pfx="$(prefix)" -v prl="$(PERL)" -v sysconfdirectory="$(sysconfdir)" -v pkgdatadirectory="$(pkgdatadir)" -f $(top_srcdir)/scripts/dosubst.awk < $(srcdir)/gnunet.conf.5.in > $(srcdir)/gnunet.conf.5
5 5
6CLEANFILES = gnunet.conf.5 6CLEANFILES = gnunet.conf.5
7 7
8if TEXI2MDOC_GENERATION
9gnunet-tutorial.7: Makefile
10 @texi2mdoc -I../tutorial:../tutorial/chapters ../tutorial/tutorial.texi > gnunet-tutorial.7
11
12gnunet-documentation.7: Makefile
13 @texi2mdoc -I../handbook:../handbook/chapters ../handbook/gnunet.texi > gnunet-documentation.7
14
15CLEANFILES += gnunet-documentation.7 gnunet-tutorial.7
16endif
17
18if HAVE_EXPERIMENTAL 8if HAVE_EXPERIMENTAL
19if HAVE_MANDOC 9if HAVE_MANDOC
20# After I went through the alternatives with the focus 10# After I went through the alternatives with the focus
@@ -24,7 +14,7 @@ if HAVE_MANDOC
24# I want and that the alternatives are depressing and 14# I want and that the alternatives are depressing and
25# nonfunctional. 15# nonfunctional.
26produce_html.sh: produce_html.sh.in Makefile 16produce_html.sh: produce_html.sh.in Makefile
27 $(AWK) -v bdir="$(bindir)" -v py="$(PYTHON)" -v awkay="$(AWK_BINARY)" -v pfx="$(prefix)" -v prl="$(PERL)" -v sysconfdirectory="$(sysconfdir)" -v pkgdatadirectory="$(pkgdatadir)" -f $(top_srcdir)/bin/dosubst.awk < $(srcdir)/produce_html.sh.in > produce_html.sh 17 $(AWK) -v bdir="$(bindir)" -v py="$(PYTHON)" -v awkay="$(AWK_BINARY)" -v pfx="$(prefix)" -v prl="$(PERL)" -v sysconfdirectory="$(sysconfdir)" -v pkgdatadirectory="$(pkgdatadir)" -f $(top_srcdir)/scripts/dosubst.awk < $(srcdir)/produce_html.sh.in > produce_html.sh
28 @chmod +x produce_html.sh 18 @chmod +x produce_html.sh
29 19
30CLEANFILES += produce_html.sh 20CLEANFILES += produce_html.sh
@@ -48,7 +38,6 @@ endif
48man_MANS = \ 38man_MANS = \
49 gnunet.conf.5 \ 39 gnunet.conf.5 \
50 gnunet-arm.1 \ 40 gnunet-arm.1 \
51 gnunet-ats.1 \
52 gnunet-auto-share.1 \ 41 gnunet-auto-share.1 \
53 gnunet-base32.1 \ 42 gnunet-base32.1 \
54 gnunet-bcd.1 \ 43 gnunet-bcd.1 \
@@ -57,10 +46,15 @@ man_MANS = \
57 gnunet-core.1 \ 46 gnunet-core.1 \
58 gnunet-conversation.1 \ 47 gnunet-conversation.1 \
59 gnunet-conversation-test.1 \ 48 gnunet-conversation-test.1 \
49 gnunet-dht-get.1 \
50 gnunet-dht-put.1 \
51 gnunet-dht-monitor.1 \
52 gnunet-dht-hello.1 \
60 gnunet-directory.1 \ 53 gnunet-directory.1 \
61 gnunet-dns2gns.1 \ 54 gnunet-dns2gns.1 \
62 gnunet-datastore.1 \ 55 gnunet-datastore.1 \
63 gnunet-download.1 \ 56 gnunet-download.1 \
57 gnunet-did.1 \
64 gnunet-ecc.1 \ 58 gnunet-ecc.1 \
65 gnunet-fs.1 \ 59 gnunet-fs.1 \
66 gnunet-gns.1 \ 60 gnunet-gns.1 \
@@ -68,14 +62,15 @@ man_MANS = \
68 gnunet-gns-proxy-setup-ca.1 \ 62 gnunet-gns-proxy-setup-ca.1 \
69 gnunet-identity.1 \ 63 gnunet-identity.1 \
70 gnunet-cadet.1 \ 64 gnunet-cadet.1 \
65 gnunet-messenger.1 \
71 gnunet-namecache.1 \ 66 gnunet-namecache.1 \
72 gnunet-namestore.1 \ 67 gnunet-namestore.1 \
73 gnunet-namestore-fcfsd.1 \ 68 gnunet-namestore-dbtool.1 \
69 gnunet-namestore-zonefile.1 \
74 gnunet-nat.1 \ 70 gnunet-nat.1 \
75 gnunet-nat-auto.1 \ 71 gnunet-nat-auto.1 \
76 gnunet-nat-server.1 \ 72 gnunet-nat-server.1 \
77 gnunet-nse.1 \ 73 gnunet-nse.1 \
78 gnunet-peerinfo.1 \
79 gnunet-publish.1 \ 74 gnunet-publish.1 \
80 gnunet-qr.1 \ 75 gnunet-qr.1 \
81 gnunet-reclaim.1 \ 76 gnunet-reclaim.1 \
@@ -85,7 +80,7 @@ man_MANS = \
85 gnunet-scrypt.1 \ 80 gnunet-scrypt.1 \
86 gnunet-search.1 \ 81 gnunet-search.1 \
87 gnunet-statistics.1 \ 82 gnunet-statistics.1 \
88 gnunet-testbed-profiler.1 \ 83 gnunet-testing.1 \
89 gnunet-testing-run-service.1 \ 84 gnunet-testing-run-service.1 \
90 gnunet-timeout.1 \ 85 gnunet-timeout.1 \
91 gnunet-transport.1 \ 86 gnunet-transport.1 \
@@ -95,10 +90,6 @@ man_MANS = \
95 gnunet-vpn.1 \ 90 gnunet-vpn.1 \
96 gnunet-zoneimport.1 91 gnunet-zoneimport.1
97 92
98if TEXI2MDOC_GENERATION
99man_MANS += gnunet-tutorial.7 gnunet-documentation.7
100endif
101
102EXTRA_DIST = ${man_MANS} \ 93EXTRA_DIST = ${man_MANS} \
103 gnunet.conf.5.in \ 94 gnunet.conf.5.in \
104 produce_html.sh.in \ 95 produce_html.sh.in \