aboutsummaryrefslogtreecommitdiff
path: root/doc/tutorial/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/tutorial/Makefile.am')
-rw-r--r--doc/tutorial/Makefile.am145
1 files changed, 145 insertions, 0 deletions
diff --git a/doc/tutorial/Makefile.am b/doc/tutorial/Makefile.am
new file mode 100644
index 000000000..0431e0684
--- /dev/null
+++ b/doc/tutorial/Makefile.am
@@ -0,0 +1,145 @@
1# This Makefile.am is in the public domain
2docdir = $(datadir)/doc/gnunet/
3
4#DOT_FILES = images/$(wildcard *.dot)
5
6#DOT_VECTOR_GRAPHICS = \
7# $(DOT_FILES:%.dot=%.eps) \
8# $(DOT_FILES:%.dot=%.pdf)
9
10AM_MAKEINFOHTMLFLAGS = --no-split --css-ref=docstyle.css
11
12#DOT_OPTIONS = \
13# -Gratio=.9 -Gnodesep=.005 -Granksep=.00005 \
14# -Nfontsite=9 -Nheight=.1 -Nwidth=.1
15
16# .dot.png:
17# $(AM_V_DOT)$(DOT) -Tpng $(DOT_OPTIONS) < "$<" > "$(srcdir)/$@.tmp"; \
18# mv "$(srcdir)/$@.tmp" "$(srcdir)/$@"
19
20# .dot.pdf:
21# $(AM_V_DOT)$(DOT) -Tpdf $(DOT_OPTIONS) < "$<" > "$(srcdir)/$@.tmp"; \
22# mv "$(srcdir)/$@.tmp" "$(srcdir)/$@"
23
24# .dot.eps:
25# $(AM_V_DOT)$(DOT) -Teps $(DOT_OPTIONS) < "$<" > "$(srcdir)/$@.tmp"; \
26# mv "$(srcdir)/$@.tmp" "$(srcdir)/$@"
27
28# .png.eps:
29# $(AM_V_GEN)convert "$<" "$@-tmp.eps"; \
30# mv "$@-tmp.eps" "$@"
31
32# pdf-local: $(DOT_FILES=%.dot=$(top_srcdir)/%.pdf)
33# info-local: $(DOT_FILES=%.dot=$(top_srcdir)/%.png)
34# ps-local: $(DOT_FILES=%.dot=$(top_srcdir)/%.eps) \
35# $(top_srcdir)/%D%/images/coreutils-size-map.eps
36# dvi-local: ps-local
37
38
39gnunet_tutorial_examples = \
40 examples/001.c \
41 examples/002.c \
42 examples/003.c \
43 examples/004.c \
44 examples/005.c \
45 examples/006.c \
46 examples/007.c \
47 examples/008.c \
48 examples/009.c \
49 examples/010.c \
50 examples/011.c \
51 examples/012.c \
52 examples/013.c \
53 examples/013.1.c \
54 examples/014.c \
55 examples/015.c \
56 examples/016.c \
57 examples/017.c \
58 examples/018.c \
59 examples/019.c \
60 examples/020.c \
61 examples/021.c \
62 examples/022.c \
63 examples/023.c \
64 examples/024.c \
65 examples/025.Makefile.am \
66 examples/026.c \
67 examples/testbed_test.c
68
69info_TEXINFOS = \
70 gnunet-tutorial.texi
71
72EXTRA_DIST = \
73 $(gnunet_tutorial_examples) \
74 htmlxref.cnf \
75 run-gendocs.sh \
76 docstyle.css
77
78
79DISTCLEANFILES = \
80 gnunet-tutorial.cps \
81 fdl-1.3.cps
82
83# XXX: is this sed invocation portable enough? otherwise try tr(1).
84version.texi/replacement: version.texi/replacement/revert
85 @sed -i "s/GPACKAGE_VERSION/$(PACKAGE_VERSION)/g" gversion.texi
86
87version.texi/replacement/revert:
88 @echo "@set VERSION GPACKAGE_VERSION" > gversion.texi
89 @echo "@set EDITION GPACKAGE_VERSION" >> gversion.texi
90
91if SECTION7
92gnunet-tutorial.7: version.texi/replacement
93 @echo Attempting to output an mdoc formatted section 7 document
94 @texi2mdoc -I$(pwd):$(pwd)/chapters gnunet-c-tutorial.texi > ../man/gnunet-c-tutorial.7
95# TODO: (Maybe) other outputs resulting from this.
96endif
97
98# FIXME: rm *.html and *.pdf
99#doc-clean:
100# @rm *.aux *.log *.toc *.cp *.cps
101
102all: version.texi/replacement
103
104doc-all-install:
105 @mkdir -p $(DESTDIR)/$(docdir)
106 @mkdir -p $(DESTDIR)/$(infoimagedir)
107 @mkdir -p $(DESTDIR)/$(infodir)
108 @install -m 0755 gnunet-tutorial.pdf $(DESTDIR)/$(docdir)
109 @install -m 0755 gnunet-tutorial.info $(DESTDIR)/$(infodir)
110 @install gnunet-tutorial.html $(DESTDIR)/$(docdir)
111
112doc-gendoc-install:
113 @mkdir -p $(DESTDIR)/$(docdir)
114 @cp -r manual $(DESTDIR)/$(docdir)
115
116# @cp -r images $(DESTDIR)/$(infoimagedir)
117
118dev-build: version.texi/replacement
119 @makeinfo --pdf gnunet-c-tutorial.texi
120 @makeinfo --html gnunet-c-tutorial.texi
121 @makeinfo --no-split gnunet-c-tutorial.texi
122
123# TODO: Add more to clean.
124clean: version.texi/replacement/revert
125 @rm -f gnunet-tutorial.pdf
126 @rm -f gnunet-tutorial.info
127 @rm -f gnunet-tutorial.html
128 @rm -fr gnunet-tutorial.t2p
129
130# CLEANFILES = \
131# gnunet.log \
132# gnunet-c-tutorial.log \
133# $(wildcard *.aux) \
134# $(wildcard *.toc) \
135# $(wildcard *.cp) \
136# $(wildcard *.cps)
137
138#.PHONY: version.texi
139# if HAVE_EXTENDED_DOCUMENTATION_BUILDING_PDF
140
141# if HAVE_EXTENDED_DOCUMENTATION_BUILDING_HTML
142
143# endif
144# endif
145# endif