aboutsummaryrefslogtreecommitdiff
path: root/lint/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lint/Makefile.am')
-rw-r--r--lint/Makefile.am22
1 files changed, 2 insertions, 20 deletions
diff --git a/lint/Makefile.am b/lint/Makefile.am
index f78cdd5f6..4ce615c47 100644
--- a/lint/Makefile.am
+++ b/lint/Makefile.am
@@ -1,25 +1,10 @@
1all: check-linters 1all: check-linters
2 2
3do_subst = $(SED) -e 's,[@]PERL[@],$(PERL),g'
4
5SUFFIXES = pl.in .pl
6
7checkbashisms.pl: checkbashisms.pl.in Makefile
8 $(do_subst) < $(srcdir)/checkbashisms.pl.in > checkbashisms.pl
9 chmod +x checkbashisms.pl
10
11CLEANFILES= \
12 checkbashisms.pl
13
14noinst_SCRIPTS = \
15 $(CLEANFILES)
16
17# Check for bashisms in shell scripts 3# Check for bashisms in shell scripts
18# Very verbose, need to exclude more files. 4# Very verbose, need to exclude more files.
19check-bashism: 5check-bashism:
20 printf "Run checkbashism on all .sh files.\n" 6 printf "If checkbashisms.pl is in PATH, run checkbashism on all .sh files.\n"
21 printf "Currently this expects checkbashism.pl at a fixed location." 7 find '..' -type f ! -path '*/.*' ! -path '*/_*' -name '*.sh' -print0 | xargs -0 checkbashisms.pl -f 2>&1 | tee $(srcdir)/bashism.log || true
22 find '..' -type f ! -path '*/.*' ! -path '*/_*' -name '*.sh' -print0 | xargs -0 $(srcdir)/checkbashisms.pl -f 2>&1 | tee $(srcdir)/bashism.log || true
23 8
24check-python: 9check-python:
25 printf "Running flake8 and 2to3 if detected.\n" 10 printf "Running flake8 and 2to3 if detected.\n"
@@ -57,6 +42,3 @@ check-texinfo:
57 @cd $(top_srcdir)/doc/tutorial ; find . -type f ! -path '*/.*' -name '*.texi' -print0 | xargs -0 awk '/XXX/ {print FILENAME":"NR":"$$0}' >> $(srcdir)/texinfo_tutorial.log || true 42 @cd $(top_srcdir)/doc/tutorial ; find . -type f ! -path '*/.*' -name '*.texi' -print0 | xargs -0 awk '/XXX/ {print FILENAME":"NR":"$$0}' >> $(srcdir)/texinfo_tutorial.log || true
58 43
59check-linters: check-bashism check-python check-man check-texinfo 44check-linters: check-bashism check-python check-man check-texinfo
60
61EXTRA_DIST = \
62 checkbashisms.pl.in