aboutsummaryrefslogtreecommitdiff
path: root/lint/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lint/Makefile.am')
-rw-r--r--lint/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/lint/Makefile.am b/lint/Makefile.am
index 59d4b6073..0de8da54a 100644
--- a/lint/Makefile.am
+++ b/lint/Makefile.am
@@ -1,5 +1,19 @@
1all: check-linters 1all: check-linters
2 2
3do_subst = $(SED) -e 's,[@]PERL[@],$(PERL),g'
4
5SUFFIXES = pl.in .pl
6
7checkbashisms.pl: checkbashisms.pl.in Makefile
8 $(do_subst) < $(srcdir)/checkbashisms.pl.in > checkbashisms.pl
9 chmod +x checkbashisms.pl
10
11CLEANFILES= \
12 checkbashisms.pl
13
14noinst_SCRIPTS = \
15 $(CLEANFILES)
16
3# Check for bashisms in shell scripts 17# Check for bashisms in shell scripts
4# Very verbose, need to exclude more files. 18# Very verbose, need to exclude more files.
5check-bashism: 19check-bashism: