aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am16
1 files changed, 11 insertions, 5 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 217aea54f..51bf2d63d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -12,7 +12,9 @@ endif
12if HAVE_EXPERIMENTAL 12if HAVE_EXPERIMENTAL
13 EXP_DIR = \ 13 EXP_DIR = \
14 rps \ 14 rps \
15 credential 15 abd \
16 reclaim-attribute \
17 reclaim
16if HAVE_ABE 18if HAVE_ABE
17 EXP_DIR += \ 19 EXP_DIR += \
18 abe 20 abe
@@ -23,7 +25,6 @@ if HAVE_JSON
23endif 25endif
24endif 26endif
25 27
26if HAVE_MHD
27if HAVE_JSON 28if HAVE_JSON
28 JSON_DIR = json 29 JSON_DIR = json
29if HAVE_LIBGNURL 30if HAVE_LIBGNURL
@@ -34,6 +35,13 @@ if HAVE_LIBCURL
34endif 35endif
35endif 36endif
36endif 37endif
38
39if BUILD_PULSE_HELPERS
40CONVERSATION_DIR = conversation
41else
42if BUILD_GST_HELPERS
43CONVERSATION_DIR = conversation
44endif
37endif 45endif
38 46
39if HAVE_SQLITE 47if HAVE_SQLITE
@@ -51,7 +59,6 @@ endif
51if HAVE_MHD 59if HAVE_MHD
52if HAVE_JSON 60if HAVE_JSON
53 REST_DIR = rest 61 REST_DIR = rest
54 RECLAIM_DIR = reclaim-attribute reclaim
55endif 62endif
56endif 63endif
57 64
@@ -109,12 +116,11 @@ SUBDIRS = \
109 vpn \ 116 vpn \
110 gns \ 117 gns \
111 zonemaster \ 118 zonemaster \
112 conversation \ 119 $(CONVERSATION_DIR) \
113 fs \ 120 fs \
114 exit \ 121 exit \
115 pt \ 122 pt \
116 secretsharing \ 123 secretsharing \
117 $(RECLAIM_DIR) \
118 $(EXP_DIR) \ 124 $(EXP_DIR) \
119 integration-tests 125 integration-tests
120 126