aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am104
1 files changed, 5 insertions, 99 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5fd00e3f5..524b989c1 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,105 +1,11 @@
1# This Makefile.am is in the public domain 1# This Makefile.am is in the public domain
2 2
3if HAVE_TESTING
4 TESTING = testing
5 TESTBED = testbed-logger testbed
6 ATS_TESTS = ats-tests
7endif
8
9if HAVE_EXPERIMENTAL
10 EXP_DIR = \
11 rps \
12 messenger
13 #abd FTBFS
14if HAVE_ABE
15 EXP_DIR += \
16 abe
17endif
18 EXP_DIR += \
19 auction
20endif
21
22JSON_DIR = json
23CURL_DIR = curl
24
25if BUILD_PULSE_HELPERS
26CONVERSATION_DIR = conversation
27else
28if BUILD_GST_HELPERS
29CONVERSATION_DIR = conversation
30endif
31endif
32
33if HAVE_SQLITE
34 SQLITE_DIR = sq
35endif
36
37if HAVE_MYSQL
38 MYSQL_DIR = mysql my
39endif
40
41if HAVE_POSTGRESQL
42 POSTGRES_DIR = pq
43endif
44
45REST_DIR = rest
46 3
47 4
48SUBDIRS = \ 5SUBDIRS = \
49 include $(INTLEMU_SUBDIRS) \ 6 include $(INTLEMU_SUBDIRS) \
50 util \ 7 lib \
51 nt \ 8 plugin \
52 hello \ 9 service \
53 block \ 10 cli \
54 statistics \ 11 contrib
55 arm \
56 $(TESTING) \
57 $(JSON_DIR) \
58 $(CURL_DIR) \
59 $(REST_DIR) \
60 peerinfo \
61 $(SQLITE_DIR) \
62 $(MYSQL_DIR) \
63 $(POSTGRES_DIR) \
64 datacache \
65 datastore \
66 template \
67 peerstore \
68 ats \
69 nat \
70 nat-auto \
71 fragmentation \
72 transport \
73 ats-tool \
74 core \
75 $(TESTBED) \
76 $(ATS_TESTS) \
77 nse \
78 dht \
79 hostlist \
80 topology \
81 regex \
82 dns \
83 identity \
84 gnsrecord \
85 namecache \
86 namestore \
87 peerinfo-tool \
88 cadet \
89 set \
90 seti \
91 setu \
92 consensus \
93 scalarproduct \
94 revocation \
95 vpn \
96 gns \
97 zonemaster \
98 $(CONVERSATION_DIR) \
99 fs \
100 exit \
101 pt \
102 secretsharing \
103 reclaim \
104 $(EXP_DIR) \
105 integration-tests