aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am22
1 files changed, 3 insertions, 19 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 4642b6215..446b1aa2a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -17,26 +17,12 @@ if HAVE_ABE
17 EXP_DIR += \ 17 EXP_DIR += \
18 abe 18 abe
19endif 19endif
20if HAVE_JSON
21 EXP_DIR += \ 20 EXP_DIR += \
22 auction 21 auction
23endif 22endif
24endif
25 23
26if HAVE_JSON 24JSON_DIR = json
27if HAVE_MHD 25CURL_DIR = curl
28 JSON_DIR = json
29endif
30endif
31if HAVE_MHD
32if HAVE_LIBGNURL
33 CURL_DIR = curl
34else
35if HAVE_LIBCURL
36 CURL_DIR = curl
37endif
38endif
39endif
40 26
41if BUILD_PULSE_HELPERS 27if BUILD_PULSE_HELPERS
42CONVERSATION_DIR = conversation 28CONVERSATION_DIR = conversation
@@ -58,9 +44,7 @@ if HAVE_POSTGRESQL
58 POSTGRES_DIR = pq 44 POSTGRES_DIR = pq
59endif 45endif
60 46
61if HAVE_REST 47REST_DIR = rest
62 REST_DIR = rest
63endif
64 48
65 49
66SUBDIRS = \ 50SUBDIRS = \