aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am19
1 files changed, 9 insertions, 10 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 61e96c75b..54f6dfab2 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -16,18 +16,20 @@ if HAVE_EXPERIMENTAL
16 psycutil \ 16 psycutil \
17 psycstore \ 17 psycstore \
18 psyc \ 18 psyc \
19 social 19 social
20# dv (FTBFS) 20# dv (FTBFS)
21if HAVE_ABE 21if HAVE_ABE
22if HAVE_JSON
22 EXP_DIR += \ 23 EXP_DIR += \
23 abe \ 24 abe \
24 credential \ 25 credential \
25 identity-attribute \ 26 reclaim-attribute \
26 identity-provider 27 reclaim
27if HAVE_ZKLAIM 28if HAVE_ZKLAIM
28 EXP_DIR += zklaim 29 EXP_DIR += zklaim
29endif 30endif
30endif 31endif
32endif
31if HAVE_JSON 33if HAVE_JSON
32 EXP_DIR += \ 34 EXP_DIR += \
33 auction 35 auction
@@ -66,9 +68,8 @@ if HAVE_POSTGRESQL
66endif 68endif
67 69
68if HAVE_MHD 70if HAVE_MHD
69 REST_DIR = rest
70if HAVE_JSON 71if HAVE_JSON
71 JSONAPI_DIR = jsonapi 72 REST_DIR = rest jsonapi rest-plugins
72endif 73endif
73endif 74endif
74 75
@@ -82,11 +83,8 @@ else
82SUBDIRS = \ 83SUBDIRS = \
83 include $(INTLEMU_SUBDIRS) \ 84 include $(INTLEMU_SUBDIRS) \
84 util \ 85 util \
85 $(JSON_DIR) \ 86 gnsrecord \
86 $(REST_DIR) \
87 $(JSONAPI_DIR) \
88 hello \ 87 hello \
89 tun \
90 block \ 88 block \
91 statistics \ 89 statistics \
92 arm \ 90 arm \
@@ -115,7 +113,6 @@ SUBDIRS = \
115 regex \ 113 regex \
116 dns \ 114 dns \
117 identity \ 115 identity \
118 gnsrecord \
119 namecache \ 116 namecache \
120 namestore \ 117 namestore \
121 peerstore \ 118 peerstore \
@@ -132,6 +129,8 @@ SUBDIRS = \
132 exit \ 129 exit \
133 pt \ 130 pt \
134 secretsharing \ 131 secretsharing \
132 $(JSON_DIR) \
133 $(REST_DIR) \
135 integration-tests \ 134 integration-tests \
136 $(EXP_DIR) 135 $(EXP_DIR)
137 136