aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am101
1 files changed, 5 insertions, 96 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 4c665c3b3..524b989c1 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,102 +1,11 @@
1# This Makefile.am is in the public domain 1# This Makefile.am is in the public domain
2 2
3TESTING = testing
4TESTBED = testbed-logger testbed
5
6if HAVE_EXPERIMENTAL
7 EXP_DIR = \
8 rps \
9 abd
10if HAVE_ABE
11 EXP_DIR += \
12 abe
13endif
14 EXP_DIR += \
15 auction
16endif
17
18JSON_DIR = json
19CURL_DIR = curl
20
21if BUILD_PULSE_HELPERS
22CONVERSATION_DIR = conversation
23else
24if BUILD_GST_HELPERS
25CONVERSATION_DIR = conversation
26endif
27endif
28
29if HAVE_SQLITE
30 SQLITE_DIR = sq
31endif
32
33if HAVE_MYSQL
34 MYSQL_DIR = mysql my
35endif
36
37if HAVE_POSTGRESQL
38 POSTGRES_DIR = pq
39endif
40
41REST_DIR = rest
42 3
43 4
44SUBDIRS = \ 5SUBDIRS = \
45 include $(INTLEMU_SUBDIRS) \ 6 include $(INTLEMU_SUBDIRS) \
46 util \ 7 lib \
47 nt \ 8 plugin \
48 hello \ 9 service \
49 block \ 10 cli \
50 statistics \ 11 contrib
51 arm \
52 $(TESTING) \
53 $(JSON_DIR) \
54 $(CURL_DIR) \
55 $(REST_DIR) \
56 peerinfo \
57 $(SQLITE_DIR) \
58 $(MYSQL_DIR) \
59 $(POSTGRES_DIR) \
60 datacache \
61 datastore \
62 template \
63 peerstore \
64 ats \
65 nat \
66 nat-auto \
67 fragmentation \
68 transport \
69 ats-tool \
70 core \
71 $(TESTBED) \
72 nse \
73 dhtu \
74 dht \
75 hostlist \
76 topology \
77 regex \
78 dns \
79 identity \
80 gnsrecord \
81 namecache \
82 namestore \
83 peerinfo-tool \
84 cadet \
85 set \
86 seti \
87 setu \
88 consensus \
89 scalarproduct \
90 revocation \
91 vpn \
92 gns \
93 zonemaster \
94 $(CONVERSATION_DIR) \
95 fs \
96 exit \
97 pt \
98 secretsharing \
99 reclaim \
100 messenger \
101 $(EXP_DIR) \
102 integration-tests