aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am103
1 files changed, 5 insertions, 98 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ef8c5b110..524b989c1 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,104 +1,11 @@
1# This Makefile.am is in the public domain 1# This Makefile.am is in the public domain
2 2
3if HAVE_TESTING
4 TESTING = testing
5 TESTBED = testbed-logger testbed
6endif
7
8if HAVE_EXPERIMENTAL
9 EXP_DIR = \
10 rps
11 #abd FTBFS
12if HAVE_ABE
13 EXP_DIR += \
14 abe
15endif
16 EXP_DIR += \
17 auction
18endif
19
20JSON_DIR = json
21CURL_DIR = curl
22
23if BUILD_PULSE_HELPERS
24CONVERSATION_DIR = conversation
25else
26if BUILD_GST_HELPERS
27CONVERSATION_DIR = conversation
28endif
29endif
30
31if HAVE_SQLITE
32 SQLITE_DIR = sq
33endif
34
35if HAVE_MYSQL
36 MYSQL_DIR = mysql my
37endif
38
39if HAVE_POSTGRESQL
40 POSTGRES_DIR = pq
41endif
42
43REST_DIR = rest
44 3
45 4
46SUBDIRS = \ 5SUBDIRS = \
47 include $(INTLEMU_SUBDIRS) \ 6 include $(INTLEMU_SUBDIRS) \
48 util \ 7 lib \
49 nt \ 8 plugin \
50 hello \ 9 service \
51 block \ 10 cli \
52 statistics \ 11 contrib
53 arm \
54 $(TESTING) \
55 $(JSON_DIR) \
56 $(CURL_DIR) \
57 $(REST_DIR) \
58 peerinfo \
59 $(SQLITE_DIR) \
60 $(MYSQL_DIR) \
61 $(POSTGRES_DIR) \
62 datacache \
63 datastore \
64 template \
65 peerstore \
66 ats \
67 nat \
68 nat-auto \
69 fragmentation \
70 transport \
71 ats-tool \
72 core \
73 $(TESTBED) \
74 nse \
75 dhtu \
76 dht \
77 hostlist \
78 topology \
79 regex \
80 dns \
81 identity \
82 gnsrecord \
83 namecache \
84 namestore \
85 peerinfo-tool \
86 cadet \
87 set \
88 seti \
89 setu \
90 consensus \
91 scalarproduct \
92 revocation \
93 vpn \
94 gns \
95 zonemaster \
96 $(CONVERSATION_DIR) \
97 fs \
98 exit \
99 pt \
100 secretsharing \
101 reclaim \
102 messenger \
103 $(EXP_DIR) \
104 integration-tests