aboutsummaryrefslogtreecommitdiff
path: root/src/ats-tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/ats-tests/Makefile.am')
-rw-r--r--src/ats-tests/Makefile.am116
1 files changed, 2 insertions, 114 deletions
diff --git a/src/ats-tests/Makefile.am b/src/ats-tests/Makefile.am
index 1804a43bf..c965fcc9f 100644
--- a/src/ats-tests/Makefile.am
+++ b/src/ats-tests/Makefile.am
@@ -9,18 +9,6 @@ if USE_COVERAGE
9 AM_CFLAGS = -fprofile-arcs -ftest-coverage 9 AM_CFLAGS = -fprofile-arcs -ftest-coverage
10endif 10endif
11 11
12if HAVE_EXPERIMENTAL
13if HAVE_LIBGLPK
14 PERF_MLP = \
15 perf_ats_mlp_transport_none \
16 perf_ats_mlp_transport_bandwidth \
17 perf_ats_mlp_transport_latency \
18 perf_ats_mlp_core_none \
19 perf_ats_mlp_core_bandwidth \
20 perf_ats_mlp_core_latency
21endif
22endif
23
24if HAVE_TESTING 12if HAVE_TESTING
25TESTING_TESTS = \ 13TESTING_TESTS = \
26 perf_ats_proportional_transport_none \ 14 perf_ats_proportional_transport_none \
@@ -31,8 +19,6 @@ TESTING_TESTS = \
31 perf_ats_proportional_core_latency \ 19 perf_ats_proportional_core_latency \
32 $(PERF_MLP) 20 $(PERF_MLP)
33 21
34# RIL-tests commented out as RIL is currently badly broken.
35# perf_ats_ril_transport_none perf_ats_ril_core_none perf_ats_ril_transport_bandwidth perf_ats_ril_core_bandwidth perf_ats_ril_transport_latency perf_ats_ril_core_latency
36endif 22endif
37 23
38lib_LTLIBRARIES = \ 24lib_LTLIBRARIES = \
@@ -56,7 +42,7 @@ libgnunetatstesting_la_SOURCES = \
56libgnunetatstesting_la_LIBADD = \ 42libgnunetatstesting_la_LIBADD = \
57 $(top_builddir)/src/testbed/libgnunettestbed.la \ 43 $(top_builddir)/src/testbed/libgnunettestbed.la \
58 $(top_builddir)/src/core/libgnunetcore.la \ 44 $(top_builddir)/src/core/libgnunetcore.la \
59 $(top_builddir)/src/transport/libgnunettransport.la \ 45 $(top_builddir)/src/transport/libgnunettransport.la \
60 $(top_builddir)/src/ats/libgnunetats.la \ 46 $(top_builddir)/src/ats/libgnunetats.la \
61 $(top_builddir)/src/util/libgnunetutil.la \ 47 $(top_builddir)/src/util/libgnunetutil.la \
62 $(GN_LIBINTL) 48 $(GN_LIBINTL)
@@ -168,106 +154,8 @@ perf_ats_proportional_transport_latency_DEPENDENCIES = \
168 libgnunetatstesting.la \ 154 libgnunetatstesting.la \
169 $(top_builddir)/src/util/libgnunetutil.la 155 $(top_builddir)/src/util/libgnunetutil.la
170 156
171perf_ats_mlp_core_none_SOURCES = \
172 perf_ats.c
173perf_ats_mlp_core_none_LDADD = \
174 $(top_builddir)/src/util/libgnunetutil.la \
175 $(top_builddir)/src/ats-tests/libgnunetatstesting.la \
176 $(top_builddir)/src/testbed/libgnunettestbed.la \
177 $(top_builddir)/src/ats/libgnunetats.la \
178 $(top_builddir)/src/core/libgnunetcore.la \
179 $(top_builddir)/src/transport/libgnunettransport.la
180perf_ats_mlp_core_none_DEPENDENCIES = \
181 libgnunetatstesting.la \
182 $(top_builddir)/src/util/libgnunetutil.la
183
184perf_ats_mlp_transport_none_SOURCES = \
185 perf_ats.c
186perf_ats_mlp_transport_none_LDADD = \
187 $(top_builddir)/src/util/libgnunetutil.la \
188 $(top_builddir)/src/ats-tests/libgnunetatstesting.la \
189 $(top_builddir)/src/testbed/libgnunettestbed.la \
190 $(top_builddir)/src/ats/libgnunetats.la \
191 $(top_builddir)/src/core/libgnunetcore.la \
192 $(top_builddir)/src/transport/libgnunettransport.la
193perf_ats_mlp_transport_none_DEPENDENCIES = \
194 libgnunetatstesting.la \
195 $(top_builddir)/src/util/libgnunetutil.la
196
197perf_ats_mlp_core_bandwidth_SOURCES = \
198 perf_ats.c
199perf_ats_mlp_core_bandwidth_LDADD = \
200 $(top_builddir)/src/util/libgnunetutil.la \
201 $(top_builddir)/src/ats-tests/libgnunetatstesting.la \
202 $(top_builddir)/src/testbed/libgnunettestbed.la \
203 $(top_builddir)/src/ats/libgnunetats.la \
204 $(top_builddir)/src/core/libgnunetcore.la \
205 $(top_builddir)/src/transport/libgnunettransport.la
206perf_ats_mlp_core_bandwidth_DEPENDENCIES = \
207 libgnunetatstesting.la \
208 $(top_builddir)/src/util/libgnunetutil.la
209
210perf_ats_mlp_transport_bandwidth_SOURCES = \
211 perf_ats.c
212perf_ats_mlp_transport_bandwidth_LDADD = \
213 $(top_builddir)/src/util/libgnunetutil.la \
214 $(top_builddir)/src/ats-tests/libgnunetatstesting.la \
215 $(top_builddir)/src/testbed/libgnunettestbed.la \
216 $(top_builddir)/src/ats/libgnunetats.la \
217 $(top_builddir)/src/core/libgnunetcore.la \
218 $(top_builddir)/src/transport/libgnunettransport.la
219perf_ats_mlp_transport_bandwidth_DEPENDENCIES = \
220 libgnunetatstesting.la \
221 $(top_builddir)/src/util/libgnunetutil.la
222
223perf_ats_mlp_core_latency_SOURCES = \
224 perf_ats.c
225perf_ats_mlp_core_latency_LDADD = \
226 $(top_builddir)/src/util/libgnunetutil.la \
227 $(top_builddir)/src/ats-tests/libgnunetatstesting.la \
228 $(top_builddir)/src/testbed/libgnunettestbed.la \
229 $(top_builddir)/src/ats/libgnunetats.la \
230 $(top_builddir)/src/core/libgnunetcore.la \
231 $(top_builddir)/src/transport/libgnunettransport.la
232perf_ats_mlp_core_latency_DEPENDENCIES = \
233 libgnunetatstesting.la \
234 $(top_builddir)/src/util/libgnunetutil.la
235
236perf_ats_mlp_transport_latency_SOURCES = \
237 perf_ats.c
238perf_ats_mlp_transport_latency_LDADD = \
239 $(top_builddir)/src/util/libgnunetutil.la \
240 $(top_builddir)/src/ats-tests/libgnunetatstesting.la \
241 $(top_builddir)/src/testbed/libgnunettestbed.la \
242 $(top_builddir)/src/ats/libgnunetats.la \
243 $(top_builddir)/src/core/libgnunetcore.la \
244 $(top_builddir)/src/transport/libgnunettransport.la
245perf_ats_mlp_transport_latencyDEPENDENCIES = \
246 $(top_builddir)/src/ats-tests/libgnunetatstesting.la \
247 $(top_builddir)/src/util/libgnunetutil.la
248
249#perf_ats_ril_core_none_SOURCES = \
250# perf_ats.c
251#perf_ats_ril_core_none_LDADD = \
252# $(top_builddir)/src/util/libgnunetutil.la \
253# $(top_builddir)/src/ats-tests/libgnunetatstesting.la \
254# $(top_builddir)/src/testbed/libgnunettestbed.la \
255# $(top_builddir)/src/ats/libgnunetats.la \
256# $(top_builddir)/src/core/libgnunetcore.la \
257# $(top_builddir)/src/transport/libgnunettransport.la
258#perf_ats_ril_core_none_DEPENDENCIES = \
259# libgnunetatstesting.la \
260# $(top_builddir)/src/util/libgnunetutil.la
261
262
263EXTRA_DIST = \ 157EXTRA_DIST = \
264 gnunet_ats_sim_default.conf \ 158 gnunet_ats_sim_default.conf \
265 perf_ats_proportional_none.conf \ 159 perf_ats_proportional_none.conf \
266 perf_ats_proportional_bandwidth.conf \ 160 perf_ats_proportional_bandwidth.conf \
267 perf_ats_proportional_latency.conf \ 161 perf_ats_proportional_latency.conf
268 perf_ats_mlp_none.conf \
269 perf_ats_mlp_bandwidth.conf \
270 perf_ats_mlp_latency.conf \
271 perf_ats_ril_none.conf \
272 perf_ats_ril_bandwidth.conf \
273 perf_ats_ril_latency.conf