summaryrefslogtreecommitdiff
path: root/src/ats-tool/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/ats-tool/Makefile.am')
-rw-r--r--src/ats-tool/Makefile.am10
1 files changed, 3 insertions, 7 deletions
diff --git a/src/ats-tool/Makefile.am b/src/ats-tool/Makefile.am
index 55bfe1322..3bb99aa08 100644
--- a/src/ats-tool/Makefile.am
+++ b/src/ats-tool/Makefile.am
@@ -1,23 +1,19 @@
1# This Makefile.am is in the public domain 1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include 2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3 3
4if MINGW
5 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
6endif
7
8if USE_COVERAGE 4if USE_COVERAGE
9 AM_CFLAGS = -fprofile-arcs -ftest-coverage 5 AM_CFLAGS = -fprofile-arcs -ftest-coverage
10endif 6endif
11 7
12bin_PROGRAMS = \ 8bin_PROGRAMS = \
13 gnunet-ats 9 gnunet-ats
14 10
15gnunet_ats_SOURCES = \ 11gnunet_ats_SOURCES = \
16 gnunet-ats.c 12 gnunet-ats.c
17gnunet_ats_LDADD = \ 13gnunet_ats_LDADD = \
18 $(top_builddir)/src/util/libgnunetutil.la \ 14 $(top_builddir)/src/util/libgnunetutil.la \
19 $(top_builddir)/src/ats/libgnunetats.la \ 15 $(top_builddir)/src/ats/libgnunetats.la \
20 $(top_builddir)/src/nt/libgnunetnt.la \ 16 $(top_builddir)/src/nt/libgnunetnt.la \
21 $(top_builddir)/src/transport/libgnunettransport.la \ 17 $(top_builddir)/src/transport/libgnunettransport.la \
22 $(top_builddir)/src/hello/libgnunethello.la \ 18 $(top_builddir)/src/hello/libgnunethello.la \
23 $(GN_LIBINTL) 19 $(GN_LIBINTL)