aboutsummaryrefslogtreecommitdiff
path: root/src/cadet/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/cadet/Makefile.am')
-rw-r--r--src/cadet/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/cadet/Makefile.am b/src/cadet/Makefile.am
index 80294a785..80a2d113d 100644
--- a/src/cadet/Makefile.am
+++ b/src/cadet/Makefile.am
@@ -30,6 +30,7 @@ lib_LTLIBRARIES = \
30 30
31libgnunetcadet_la_SOURCES = \ 31libgnunetcadet_la_SOURCES = \
32 cadet_api.c \ 32 cadet_api.c \
33 cadet_api_drop_message.c \
33 cadet_api_get_channel.c \ 34 cadet_api_get_channel.c \
34 cadet_api_get_path.c \ 35 cadet_api_get_path.c \
35 cadet_api_list_peers.c \ 36 cadet_api_list_peers.c \
@@ -96,6 +97,7 @@ check_PROGRAMS = \
96 test_cadet_2_speed_reliable \ 97 test_cadet_2_speed_reliable \
97 test_cadet_2_speed_reliable_backwards \ 98 test_cadet_2_speed_reliable_backwards \
98 test_cadet_2_reopen \ 99 test_cadet_2_reopen \
100 test_cadet_2_destroy \
99 test_cadet_5_forward \ 101 test_cadet_5_forward \
100 test_cadet_5_signal \ 102 test_cadet_5_signal \
101 test_cadet_5_keepalive \ 103 test_cadet_5_keepalive \
@@ -217,6 +219,9 @@ test_cadet_5_reopen_SOURCES = \
217 test_cadet.c 219 test_cadet.c
218test_cadet_5_reopen_LDADD = $(ld_cadet_test_lib) 220test_cadet_5_reopen_LDADD = $(ld_cadet_test_lib)
219 221
222test_cadet_2_destroy_SOURCES = \
223 test_cadet.c
224test_cadet_2_destroy_LDADD = $(ld_cadet_test_lib)
220 225
221if ENABLE_TEST_RUN 226if ENABLE_TEST_RUN
222AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME; 227AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;