aboutsummaryrefslogtreecommitdiff
path: root/src/cadet/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/cadet/Makefile.am')
-rw-r--r--src/cadet/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/cadet/Makefile.am b/src/cadet/Makefile.am
index d8d81bf20..2289a2d96 100644
--- a/src/cadet/Makefile.am
+++ b/src/cadet/Makefile.am
@@ -30,6 +30,7 @@ lib_LTLIBRARIES = \
30 30
31libgnunetcadet_la_SOURCES = \ 31libgnunetcadet_la_SOURCES = \
32 cadet_api.c \ 32 cadet_api.c \
33 cadet_api_drop_message.c \
33 cadet_api_get_channel.c \ 34 cadet_api_get_channel.c \
34 cadet_api_get_path.c \ 35 cadet_api_get_path.c \
35 cadet_api_list_peers.c \ 36 cadet_api_list_peers.c \
@@ -95,6 +96,7 @@ check_PROGRAMS = \
95 test_cadet_2_speed_reliable \ 96 test_cadet_2_speed_reliable \
96 test_cadet_2_speed_reliable_backwards \ 97 test_cadet_2_speed_reliable_backwards \
97 test_cadet_2_reopen \ 98 test_cadet_2_reopen \
99 test_cadet_2_destroy \
98 test_cadet_5_forward \ 100 test_cadet_5_forward \
99 test_cadet_5_signal \ 101 test_cadet_5_signal \
100 test_cadet_5_keepalive \ 102 test_cadet_5_keepalive \
@@ -211,6 +213,9 @@ test_cadet_5_reopen_SOURCES = \
211 test_cadet.c 213 test_cadet.c
212test_cadet_5_reopen_LDADD = $(ld_cadet_test_lib) 214test_cadet_5_reopen_LDADD = $(ld_cadet_test_lib)
213 215
216test_cadet_2_destroy_SOURCES = \
217 test_cadet.c
218test_cadet_2_destroy_LDADD = $(ld_cadet_test_lib)
214 219
215if ENABLE_TEST_RUN 220if ENABLE_TEST_RUN
216AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME; 221AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;