aboutsummaryrefslogtreecommitdiff
path: root/src/cadet/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/cadet/Makefile.am')
-rw-r--r--src/cadet/Makefile.am229
1 files changed, 0 insertions, 229 deletions
diff --git a/src/cadet/Makefile.am b/src/cadet/Makefile.am
deleted file mode 100644
index 2289a2d96..000000000
--- a/src/cadet/Makefile.am
+++ /dev/null
@@ -1,229 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if USE_COVERAGE
5 AM_CFLAGS = --coverage -O0
6 XLIB = -lgcov
7endif
8
9pkgcfgdir= $(pkgdatadir)/config.d/
10
11libexecdir= $(pkglibdir)/libexec/
12
13pkgcfg_DATA = \
14 cadet.conf
15
16plugindir = $(libdir)/gnunet
17
18AM_CLFAGS = -g
19
20libexec_PROGRAMS = \
21 gnunet-service-cadet \
22 $(EXP_LIBEXEC)
23
24bin_PROGRAMS = \
25 gnunet-cadet
26
27lib_LTLIBRARIES = \
28 libgnunetcadet.la \
29 $(EXP_LIB)
30
31libgnunetcadet_la_SOURCES = \
32 cadet_api.c \
33 cadet_api_drop_message.c \
34 cadet_api_get_channel.c \
35 cadet_api_get_path.c \
36 cadet_api_list_peers.c \
37 cadet_api_list_tunnels.c \
38 cadet_api_helper.c
39libgnunetcadet_la_LIBADD = \
40 $(top_builddir)/src/util/libgnunetutil.la \
41 $(XLIB) \
42 $(LTLIBINTL)
43libgnunetcadet_la_LDFLAGS = \
44 $(GN_LIB_LDFLAGS) \
45 -version-info 7:0:0
46
47gnunet_cadet_SOURCES = \
48 gnunet-cadet.c
49gnunet_cadet_LDADD = \
50 libgnunetcadet.la \
51 $(top_builddir)/src/util/libgnunetutil.la
52gnunet_cadet_LDFLAGS = \
53 $(GN_LIBINTL)
54
55gnunet_service_cadet_SOURCES = \
56 gnunet-service-cadet.c gnunet-service-cadet.h \
57 gnunet-service-cadet_channel.c gnunet-service-cadet_channel.h \
58 gnunet-service-cadet_connection.c gnunet-service-cadet_connection.h \
59 gnunet-service-cadet_core.c gnunet-service-cadet_core.h \
60 gnunet-service-cadet_dht.c gnunet-service-cadet_dht.h \
61 gnunet-service-cadet_hello.c gnunet-service-cadet_hello.h \
62 gnunet-service-cadet_tunnels.c gnunet-service-cadet_tunnels.h \
63 gnunet-service-cadet_paths.c gnunet-service-cadet_paths.h \
64 gnunet-service-cadet_peer.c gnunet-service-cadet_peer.h
65gnunet_service_cadet_LDADD = \
66 $(top_builddir)/src/util/libgnunetutil.la \
67 $(top_builddir)/src/ats/libgnunetats.la \
68 $(top_builddir)/src/core/libgnunetcore.la \
69 $(top_builddir)/src/dht/libgnunetdht.la \
70 $(top_builddir)/src/statistics/libgnunetstatistics.la \
71 $(top_builddir)/src/transport/libgnunettransport.la \
72 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
73 $(top_builddir)/src/hello/libgnunethello.la \
74 $(top_builddir)/src/block/libgnunetblock.la
75if LINUX
76 gnunet_service_cadet_LDFLAGS = -lrt \
77 $(GN_LIBINTL)
78endif
79
80
81if HAVE_TESTING
82 noinst_LTLIBRARIES = libgnunetcadettest.la $(noinst_LIB_EXP)
83# noinst_PROGRAMS = gnunet-cadet-profiler
84endif
85
86if HAVE_TESTING
87check_PROGRAMS = \
88 test_cadet_local_mq \
89 test_cadet_2_forward \
90 test_cadet_2_forward \
91 test_cadet_2_signal \
92 test_cadet_2_keepalive \
93 test_cadet_2_speed \
94 test_cadet_2_speed_ack \
95 test_cadet_2_speed_backwards \
96 test_cadet_2_speed_reliable \
97 test_cadet_2_speed_reliable_backwards \
98 test_cadet_2_reopen \
99 test_cadet_2_destroy \
100 test_cadet_5_forward \
101 test_cadet_5_signal \
102 test_cadet_5_keepalive \
103 test_cadet_5_speed \
104 test_cadet_5_speed_ack \
105 test_cadet_5_speed_reliable \
106 test_cadet_5_speed_reliable_backwards \
107 test_cadet_5_speed_backwards \
108 test_cadet_5_reopen
109endif
110
111
112#gnunet_cadet_profiler_SOURCES = \
113# gnunet-cadet-profiler.c
114#gnunet_cadet_profiler_LDADD = $(ld_cadet_test_lib)
115
116
117test_cadet_local_mq_SOURCES = \
118 test_cadet_local_mq.c
119test_cadet_local_mq_LDADD = \
120 libgnunetcadet.la \
121 $(top_builddir)/src/testing/libgnunettesting.la \
122 $(top_builddir)/src/util/libgnunetutil.la
123
124
125libgnunetcadettest_la_SOURCES = \
126 cadet_test_lib.c cadet_test_lib.h
127libgnunetcadettest_la_LIBADD = \
128 $(top_builddir)/src/util/libgnunetutil.la \
129 $(top_builddir)/src/testbed/libgnunettestbed.la \
130 libgnunetcadet.la
131
132ld_cadet_test_lib = \
133 $(top_builddir)/src/util/libgnunetutil.la \
134 $(top_builddir)/src/testing/libgnunettesting.la \
135 libgnunetcadet.la \
136 libgnunetcadettest.la \
137 $(top_builddir)/src/testbed/libgnunettestbed.la \
138 $(top_builddir)/src/statistics/libgnunetstatistics.la
139dep_cadet_test_lib = \
140 libgnunetcadet.la \
141 libgnunetcadettest.la \
142 $(top_builddir)/src/statistics/libgnunetstatistics.la
143
144test_cadet_2_forward_SOURCES = \
145 test_cadet.c
146test_cadet_2_forward_LDADD = $(ld_cadet_test_lib)
147
148test_cadet_2_signal_SOURCES = \
149 test_cadet.c
150test_cadet_2_signal_LDADD = $(ld_cadet_test_lib)
151
152test_cadet_2_keepalive_SOURCES = \
153 test_cadet.c
154test_cadet_2_keepalive_LDADD = $(ld_cadet_test_lib)
155
156test_cadet_2_speed_SOURCES = \
157 test_cadet.c
158test_cadet_2_speed_LDADD = $(ld_cadet_test_lib)
159
160test_cadet_2_speed_ack_SOURCES = \
161 test_cadet.c
162test_cadet_2_speed_ack_LDADD = $(ld_cadet_test_lib)
163
164test_cadet_2_speed_backwards_SOURCES = \
165 test_cadet.c
166test_cadet_2_speed_backwards_LDADD = $(ld_cadet_test_lib)
167
168test_cadet_2_speed_reliable_SOURCES = \
169 test_cadet.c
170test_cadet_2_speed_reliable_LDADD = $(ld_cadet_test_lib)
171
172test_cadet_2_speed_reliable_backwards_SOURCES = \
173 test_cadet.c
174test_cadet_2_speed_reliable_backwards_LDADD = $(ld_cadet_test_lib)
175
176test_cadet_5_forward_SOURCES = \
177 test_cadet.c
178test_cadet_5_forward_LDADD = $(ld_cadet_test_lib)
179
180test_cadet_5_signal_SOURCES = \
181 test_cadet.c
182test_cadet_5_signal_LDADD = $(ld_cadet_test_lib)
183
184test_cadet_5_keepalive_SOURCES = \
185 test_cadet.c
186test_cadet_5_keepalive_LDADD = $(ld_cadet_test_lib)
187
188test_cadet_5_speed_SOURCES = \
189 test_cadet.c
190test_cadet_5_speed_LDADD = $(ld_cadet_test_lib)
191
192test_cadet_5_speed_ack_SOURCES = \
193 test_cadet.c
194test_cadet_5_speed_ack_LDADD = $(ld_cadet_test_lib)
195
196test_cadet_5_speed_backwards_SOURCES = \
197 test_cadet.c
198test_cadet_5_speed_backwards_LDADD = $(ld_cadet_test_lib)
199
200test_cadet_5_speed_reliable_SOURCES = \
201 test_cadet.c
202test_cadet_5_speed_reliable_LDADD = $(ld_cadet_test_lib)
203
204test_cadet_5_speed_reliable_backwards_SOURCES = \
205 test_cadet.c
206test_cadet_5_speed_reliable_backwards_LDADD = $(ld_cadet_test_lib)
207
208test_cadet_2_reopen_SOURCES = \
209 test_cadet.c
210test_cadet_2_reopen_LDADD = $(ld_cadet_test_lib)
211
212test_cadet_5_reopen_SOURCES = \
213 test_cadet.c
214test_cadet_5_reopen_LDADD = $(ld_cadet_test_lib)
215
216test_cadet_2_destroy_SOURCES = \
217 test_cadet.c
218test_cadet_2_destroy_LDADD = $(ld_cadet_test_lib)
219
220if ENABLE_TEST_RUN
221AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
222TESTS = \
223 $(check_PROGRAMS)
224endif
225
226EXTRA_DIST = \
227 cadet.h cadet_protocol.h \
228 test_cadet.conf \
229 test_cadet_drop.conf