aboutsummaryrefslogtreecommitdiff
path: root/src/consensus/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/consensus/Makefile.am')
-rw-r--r--src/consensus/Makefile.am120
1 files changed, 0 insertions, 120 deletions
diff --git a/src/consensus/Makefile.am b/src/consensus/Makefile.am
deleted file mode 100644
index cf1d32e74..000000000
--- a/src/consensus/Makefile.am
+++ /dev/null
@@ -1,120 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4pkgcfgdir= $(pkgdatadir)/config.d/
5
6libexecdir= $(pkglibdir)/libexec/
7
8plugindir = $(libdir)/gnunet
9
10pkgcfg_DATA = \
11 consensus.conf
12
13if USE_COVERAGE
14 AM_CFLAGS = -fprofile-arcs -ftest-coverage
15endif
16
17
18libexec_PROGRAMS = \
19 gnunet-service-consensus
20
21if ENABLE_MALICIOUS
22libexec_PROGRAMS += \
23 gnunet-service-evil-consensus
24endif
25
26SUFFIXES = .py.in .py
27
28.py.in.py:
29 $(AWK) -v bdir="$(bindir)" -v py="$(PYTHON)" -v awkay="$(AWK_BINARY)" -v pfx="$(prefix)" -v prl="$(PERL)" -v sysconfdirectory="$(sysconfdir)" -v pkgdatadirectory="$(pkgdatadir)" -f $(top_srcdir)/bin/dosubst.awk < $< > $@
30 chmod +x $@
31
32check-python-style:
33 flake8 consensus-simulation.py.in
34
35lib_LTLIBRARIES = \
36 libgnunetconsensus.la
37
38gnunet_consensus_profiler_SOURCES = \
39 gnunet-consensus-profiler.c
40gnunet_consensus_profiler_LDADD = \
41 $(top_builddir)/src/util/libgnunetutil.la \
42 libgnunetconsensus.la \
43 $(top_builddir)/src/testing/libgnunettesting.la \
44 $(top_builddir)/src/testbed/libgnunettestbed.la \
45 $(GN_LIBINTL)
46
47gnunet_service_consensus_SOURCES = \
48 gnunet-service-consensus.c
49gnunet_service_consensus_LDADD = \
50 $(top_builddir)/src/util/libgnunetutil.la \
51 $(top_builddir)/src/core/libgnunetcore.la \
52 $(top_builddir)/src/set/libgnunetset.la \
53 $(top_builddir)/src/statistics/libgnunetstatistics.la \
54 $(GN_LIBINTL)
55
56gnunet_service_evil_consensus_SOURCES = \
57 gnunet-service-consensus.c \
58 consensus_protocol.h
59gnunet_service_evil_consensus_LDADD = \
60 $(top_builddir)/src/util/libgnunetutil.la \
61 $(top_builddir)/src/core/libgnunetcore.la \
62 $(top_builddir)/src/set/libgnunetset.la \
63 $(top_builddir)/src/statistics/libgnunetstatistics.la \
64 $(GN_LIBINTL)
65gnunet_service_evil_consensus_CFLAGS = -DEVIL
66
67libgnunetconsensus_la_SOURCES = \
68 consensus_api.c \
69 consensus.h
70libgnunetconsensus_la_LIBADD = \
71 $(top_builddir)/src/util/libgnunetutil.la \
72 $(LTLIBINTL)
73libgnunetconsensus_la_LDFLAGS = \
74 $(GN_LIB_LDFLAGS)
75
76
77plugin_LTLIBRARIES = \
78 libgnunet_plugin_block_consensus.la
79
80libgnunet_plugin_block_consensus_la_SOURCES = \
81 plugin_block_consensus.c
82libgnunet_plugin_block_consensus_la_LIBADD = \
83 $(top_builddir)/src/block/libgnunetblock.la \
84 $(top_builddir)/src/block/libgnunetblockgroup.la \
85 $(top_builddir)/src/util/libgnunetutil.la \
86 $(LTLIBINTL)
87libgnunet_plugin_block_consensus_la_LDFLAGS = \
88 $(GN_PLUGIN_LDFLAGS)
89
90
91
92if HAVE_TESTING
93bin_PROGRAMS = \
94 gnunet-consensus-profiler
95
96check_PROGRAMS = \
97 test_consensus_api
98
99if ENABLE_TEST_RUN
100AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
101TESTS = $(check_PROGRAMS)
102endif
103endif
104
105test_consensus_api_SOURCES = \
106 test_consensus_api.c
107test_consensus_api_LDADD = \
108 $(top_builddir)/src/util/libgnunetutil.la \
109 $(top_builddir)/src/testing/libgnunettesting.la \
110 libgnunetconsensus.la
111
112noinst_SCRIPTS = \
113 consensus-simulation.py
114
115CLEANFILES = \
116 $(noinst_SCRIPTS)
117
118EXTRA_DIST = \
119 test_consensus.conf \
120 consensus-simulation.py.in